Formule incomplète

T

tintmarre

Guest
bonsoir à tous,

j'ai récupéré il y a quelque temps une formule sur le forum que j'ai essayé d'adapter pour le tableau ci-joint

j'ai adapaté 2/3 choses et les formules fonctionnent mais mon souci est le suivant : il me manque un argument

explication : dans mon tableau j'ai 3 colonnes à la fin qui me font le total en fonction notamment de la colonne 'C'
en gros si c'est 'Fr' ça me comptera les FR, si c'est euro, les euro etc...mon problème est que j'indique dans les 2 autres colonnes D et E si c'est Fr et Euro ou Fr seulement ou Euro seulement

suis je clair ? j'ai du mal à me comprendre moi même :/
en gros je souhaiterais qu'en fonction de la nationalité Fr (en colonne C) ma formule vérifie si c'est Yes en colonne D pour faire le total en colonne R et si c'est Yes en colonne E pour faire le total en colonne S

dans mon tableau, la formule compte 1:24:00 pour 'pierre' mais comme j'ai indiqué Yes dans la colonne E je souhaiterais que cela m'indique aussi 1:24:00 dans la colonne S


j'ai essayé de détailler au max :/
si l'un d'entre vous à une idée, suis preneur ;)

merci beaucoup et bonne nuitée ! [file name=Classeur2_20051020001548.zip size=7415]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/Classeur2_20051020001548.zip[/file]
 

Pièces jointes

  • Classeur2_20051020001548.zip
    7.2 KB · Affichages: 7

ZZR09

XLDnaute Occasionnel
Bonjour tintmarre,

Ci-joint une modification sur ton fichier.

En C:
=SI(C6='';'';SI(C6='Fr';'Y';'N'))

En D:
=SI(C6='';'';SI(OU(C6='Fr';C6='Euro');'Y';'N'))

En R et S, c'est le même principe mais avec un test sur la présence de 'Y' en D6 ou E6 une multiplication de F6 par Q6 à la place du dernier 'Y' de la formule.

En espérant que c'est ce que tu voulais.

A+
;) [file name=Classeur3_20051020070038.zip size=7836]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/Classeur3_20051020070038.zip[/file]
 

Pièces jointes

  • Classeur3_20051020070038.zip
    7.7 KB · Affichages: 6

Charly2

Nous a quittés en 2006
Repose en paix
Bonjour tintmarre, ZZR09, Chantal, le forum,

Tintmarre, j'ai modifié ta formule afin qu'elle tienne compte des cellules dont tu parlais car comme dit Chantal, tu avais oublié de prendre en compte les valeurs des cellules D6 et D7.

Le début de ta formule est modifié comme suit :

=SI(OU(ET($C6<>S$5;D6<>'Y');....

Je te joins le fichier avec la rectification.

Amicalement
Charly [file name=Tintmarre.zip size=7934]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/Tintmarre.zip[/file]
 

Pièces jointes

  • Tintmarre.zip
    7.7 KB · Affichages: 14
  • Tintmarre.zip
    7.7 KB · Affichages: 14
  • Tintmarre.zip
    7.7 KB · Affichages: 10
T

tintmarre

Guest
re ;)

bah euh ça a l'air de marcher :) merci bp (je dois reverifier 2/3 trucs mais ça m'a l'air tout bon, 'my god' je vais gagner du temps)


puis-je demander autre chose concernant ce même doc ?!
bon j'me lance
en fait j'aimerais partir d'un planning semaine (sur un autre onglet) avec les jours de la semaine et les heures en colonne :silly:

bon j'aimerais me simplifier la vie en gros :)
vous parait-il possible en faisant le planning sur l'onglet planning que les données s'ajoutent dans l'onglet test en fonction des horaires ?

hum je sais moi même je suis dépassé...
 
T

tintmarre

Guest
oups le doc [file name=Classeur2bis_20051020233220.zip size=8045]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/Classeur2bis_20051020233220.zip[/file]
 

Pièces jointes

  • Classeur2bis_20051020233220.zip
    7.9 KB · Affichages: 6

Statistiques des forums

Discussions
312 962
Messages
2 093 989
Membres
105 906
dernier inscrit
aifa