formule DROITE extraire 1 à 3 chiffres

coulou

XLDnaute Occasionnel
Bonsoir le forum je voudrais extraire 2 à 3 chiffres avec la formule DROITE mais sans les symboles comme les deux points ou les tirets dans l'attente d'une réponse je mets un fichier .
Merçi d'avance
 

Pièces jointes

  • extraire les chiffres.xls
    13.5 KB · Affichages: 47
  • extraire les chiffres.xls
    13.5 KB · Affichages: 49
  • extraire les chiffres.xls
    13.5 KB · Affichages: 50

Staple1600

XLDnaute Barbatruc
Re : formule DROITE extraire 1 à 3 chiffres

Re

Voilà ce donne l’enregistreur de macros en utilisant Edition/Remplacer
Code VB:
Sub Macro1()
Selection.Replace What:="courues :", Replacement:="", LookAt:=xlPart, _
SearchOrder:=xlByRows, MatchCase:=False, SearchFormat:=False, _
ReplaceFormat:=False
Selection.Replace What:="places :", Replacement:="", LookAt:=xlPart, _
SearchOrder:=xlByRows, MatchCase:=False, SearchFormat:=False, _
ReplaceFormat:=False
Selection.Replace What:="victoires :", Replacement:="", LookAt:=xlPart, _
SearchOrder:=xlByRows, MatchCase:=False, SearchFormat:=False, _
ReplaceFormat:=False
Selection.Replace What:="-", Replacement:="", LookAt:=xlPart, _
SearchOrder:=xlByRows, MatchCase:=False, SearchFormat:=False, _
ReplaceFormat:=False
End Sub
 

Staple1600

XLDnaute Barbatruc
Re : formule DROITE extraire 1 à 3 chiffres

Re


Si tu veux le faire par formules
Code:
=SI(ESTERR(STXT(C11;CHERCHE(":";C11)+1;3)*1);"";STXT(C11;CHERCHE(":";C11)+1;3)*1)
(en insérant au préalable une colonne entre chaque colonne existante)
donc ici mettre cette formule en D11 (qui sera vide puisque tu viendras d'insérer une colonne)
 
Dernière édition:

JHA

XLDnaute Barbatruc
Re : formule DROITE extraire 1 à 3 chiffres

Bonsoir à tous,

Voir fichier joint

JHA
 

Pièces jointes

  • extraire les chiffres.xls
    19 KB · Affichages: 47
  • extraire les chiffres.xls
    19 KB · Affichages: 48
  • extraire les chiffres.xls
    19 KB · Affichages: 50

Staple1600

XLDnaute Barbatruc
Re : formule DROITE extraire 1 à 3 chiffres

Re, Bonsoir JHA, JCGL

Comme c'est fait, inutile que cela reste dans mon VBE
Code VBA:
Sub a()
Dim c As Range, p As Range
Range("B10:Q13").Name = "ZONE"
For Each c In [ZONE]
Select Case c.Column Mod 2
Case 1
c.Insert Shift:=xlToRight, CopyOrigin:=xlFormatFromLeftOrAbove
End Select
Next c
Application.Goto Reference:="ZONE"
Set p = Selection.SpecialCells(xlCellTypeBlanks)
p.FormulaR1C1 = "=IF(ISERR(MID(RC[-1],SEARCH("":"",RC[-1])+1,3)*1),"""",MID(RC[-1],SEARCH("":"",RC[-1])+1,3)*1)"
End Sub
 

Discussions similaires

Statistiques des forums

Discussions
312 923
Messages
2 093 663
Membres
105 780
dernier inscrit
Autric