Formats conditionnels assez compliqués...

Christian0258

XLDnaute Accro
Bonjour à tout le forum,

Je souhaiterais vos lumières pour savoir si les formats conditionnels, souhaités dans ce fichier, sont réalisables?

voir fichier joint

Merci, à nouveau, pour votre aide si précieuse.

Bien amicalement,
Christian
 

Pièces jointes

  • Format conditonnel assez compliqué....xlsm
    20.2 KB · Affichages: 36

gosselien

XLDnaute Barbatruc
Bonjour,

un format condi fonctionne si le résultat est 0/1 ou vrai/faux donc si tu mets un si devant ta formule ça devrait fonctionner :

=SI($A$4="";"";SI(ET(B$1="";B$2="");"";SI(ET(B$1=$A$4;B$2=$A$4);1;SI(B$1=$A$4;0.5;SI(B$2=$A$4;0.5;"")))))<>""
qui répond vrai ou faux donc coloré ou pas :)

P.
 

JHA

XLDnaute Barbatruc
Bonjour à tous,

Comme le dit notre ami "Gosselien" que je salue:), il est possible de mettre une MFC si estnum() ou non.

Maintenant, il est plus difficile de savoir pourquoi tu colores en vert ou en rose (est ce par semaine, par cycle, etc..). Peux tu nous en dire un peu plus sur la condition des couleurs car je ne vois pas de corrélation.

JHA
 

Christian0258

XLDnaute Accro
Re, bonsoir à tout le forum, gosselien, JHA

Merci à vous deux pour votre aide.
Oui effectivement, gosselien, ta solution fonctionne.
JHA pas eu le temps de te préciser suite à ton (post5), mais ta solution post6 est tout à fait ce que j'attendais.
Changer la couleur lors qu'un nouveau CA ou nouvelle série de CA démarre...Merci JHA c'est impeccable.

Encore merci à vous deux.
Bien à vous,
Christian
 

Discussions similaires

Statistiques des forums

Discussions
312 816
Messages
2 092 331
Membres
105 367
dernier inscrit
jych