Fonction Si / Conditions multiples / calcul d'une prime

Nemo Auditur

XLDnaute Nouveau
Chers Tous,

Je souhaiterais pouvoir constituer le calcul automatique d'une prime dont le montant varie en fonction de l'ancienneté…

J'ai deux colonnes reprenant les valeurs suivantes:

- En B2 des montants équivalents à des salaires bruts mensuels ;
- En C2 des nombres équivalents à une ancienneté.

Dans une autre colonne (E2) je souhaiterais estimer le montant de la prime sur la base des écarts suivant:

moins de 2 ans d'ancienneté → 4*B2
entre 2 et 5 ans d'ancienneté → 6*B2
entre 5 et 8 ans d'ancienneté → 10*B2
entre 8 et 10 ans d'ancienneté→ 12*B2
entre 10 et 15 ans d'ancienneté → 14*B2
plus de 15 ans d'ancienneté → 18*B2

Auriez-vous une idée d'une formule Excel correspondante?

Bien à vous tous,
 

VDAVID

XLDnaute Impliqué
Re : Fonction Si / Conditions multiples / calcul d'une prime

Bonjour Nemo Auditur,

Un fichier exemple n'aurait pas été superflu :)

Ci-joint un test en passant par un tableau intermédiaire + recherchev
J'espère que c'est ce que tu souhaitais obtenir
Bonne soirée!
 

Pièces jointes

  • Test Nemo Auditur.xlsx
    10.4 KB · Affichages: 676

Dormeur74

XLDnaute Occasionnel
Re : Fonction Si / Conditions multiples / calcul d'une prime

Cette formule devrait le permettre :

Code:
=SI(C2>15;18*B2;SI(C2>=10;14*B2;SI(C2>=8;12*B2;SI(C2>=5;10*B2;SI(C2>=2;6*B2;4*B2)))))

A tirer jusqu'en bas sur la colonne des primes.
 

Discussions similaires

Statistiques des forums

Discussions
312 927
Messages
2 093 679
Membres
105 781
dernier inscrit
Dominique G.