XL 2016 Fonction si avec cellule vide et cellule non vide

vinie74

XLDnaute Nouveau
Bonjour,

Je n'arrive pas à trouver la bonne formule . Je m'explique dans mon tableau EXCEL j'ai une 1ère date (colonne jamais vide = R) La colonne S peut contenir une date mais pas nécessairement. La colonne T doit me donner la date de la colonne R + 3 mois (soit 93 jours) si la colonne S est vide et si la colonne S contient une date la colonne T doit donc me donner la date S + 3 mois (soit 93 jours). J'espère que vous avez compris 😁

J'ai noté la formule suivante dans la colonne T mais elle ne répond pas à ce que je désire :

=SI(ESTVIDE(S5);R5+93;SI(S-5;S5+93;""))

1692954296264.png


Je vous remercie pour vos retour.

virginie
 

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonjour Vinie, et bienvenue sur XLD, bonjour Cousinhub,
Un petit fichier test aurait été le bienvenu, ne serait ce que pour éviter de se retaper le fichier. :)
Dans votre formule "S-5" ne veut rien dire, à mon avis.
D'après ce que j'ai compris, j'aurais fait :
Code:
=SI(ESTVIDE(S5);SI(ESTVIDE(R5);"";R5+93);S5+93)
Si S et R vide alors rien
Si S vide R non vide alors R+93
Si S non vide alors S+93
 

Discussions similaires

  • Résolu(e)
Microsoft 365 Formule SI
Réponses
4
Affichages
257

Statistiques des forums

Discussions
313 329
Messages
2 097 234
Membres
106 883
dernier inscrit
Papalo