Fonction RECHERCHEV() avec plage variable

A

Audrey

Guest
Bonjour,
Voici le problème auquel je suis confrontée.
Je dois faire une recherche dans un tableau à l'aide de la fonction RECHERCHEV(Valeur;PlageTablo;IndiceCol)
Le problème est que la plage est variable en fonction d'une autre données. Et j'ai une trentaine de plage à gérer.
Et chaque fois que j'essai d'indiquer le nom de la plage dans la fonction RECHERCHEV() autrement qu'en la saisissant en brut j'ai l'erreur #NA qui est retournée.
J'ai essayé de lui indiquer :
RECHERCHEV(Valeur;H13;IndiceCol) H13 = plage1

Quelqu'un à t'il une idée?
Merci d'avance pour vos réponses.
Audrey

Infos supp :
OS WINXP
Excel 2000
 

Dan

XLDnaute Barbatruc
Bonjour,

Avec un fichier ce serait plus facile mais veille à ce ceci :

=RechercheV(valeur;Plage;colonne;Faux)

Avec :
- Valeur = la valeur à chercher
- Plage = la plage de référence
- Colonne = la colonne de la plage de référence dans laquelle tu obtiens la donnée
- Faux : te permet de ne pas perdre les informations notamment en cas de tri. tu peux aussi remplacer Faux par 0.


;)
 
A

Audrey

Guest
Merci pour votre aide mais je crois que les solutions proposées ne correspondent pas à mon problème ou alors je ne sais pas les mettre en place.
Je joins un fichier qui parlera surement mieux.
Merci

[file name=FonctionRechercheV.zip size=2303]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/FonctionRechercheV.zip[/file]
 

Pièces jointes

  • FonctionRechercheV.zip
    2.2 KB · Affichages: 460
A

audrey

Guest
Bonjour
Merci à tous, un ami m'a donné la solution
Il suffit de mettre la fonction INDIRECT().
Renvoie la référence spécifiée par une chaîne de caractères

=RECHERCHEV(D12;INDIRECT(D13);6)

Merci bcp pour vos aides.
 

Discussions similaires

Statistiques des forums

Discussions
300 823
Messages
1 987 483
Membres
209 865
dernier inscrit
MALICK SENE