Fonction : Afficher la valeur d'une cellule adjacente ?

junty94

XLDnaute Nouveau
Bonjour,

J'ai une question sur l'usage des fonctions.

En gros, j'ai dans une feuille le total des points de 3 joueurs à un jeu.

A B C
1 Pierre Paul Jean
2 10 20 30


Comment faire avec une fonction pour afficher dans une autre cellule le nom du joueur ayant le minimum ?

C'est a dire afficher la cellule située juste au-dessus de Min(A2:C2) ?

Merci d'avance pour la réponse!
 

skoobi

XLDnaute Barbatruc
Re : Fonction : Afficher la valeur d'une cellule adjacente ?

Bonjour junty94, bienvenue sur XLD,

voir la PJ, formule en B4.

Edit: salut Tibo :), tu commences à avoir de la concurrence...... :D lol
 

Pièces jointes

  • Afficher la valeur d'une cellule adjacente.xls
    15.5 KB · Affichages: 382

junty94

XLDnaute Nouveau
Re : Fonction : Afficher la valeur d'une cellule adjacente ?

Super ! merci Tibo ca marche parfaitement.

Effectivement gérer les doublons pourraient être un plus mais ca n'est pas indispensable pour moi... (par défaut Excel doit prendre la première valeur de la zone en question)..

D'après toi, y aurait-il possibilité d'afficher toutes les valeurs minimum séparées par un espace par exemple ?

Sachant que je n'ai que 5 joueurs.... On peut prendre le risque d'afficher tous les noms si les scores étaient par exemple tous nuls.

En tout cas merci pour ton aide !

Junty94



Bonjour,

Essaye avec :

Code:
=INDEX(A1:C1;EQUIV(MIN(A2:C2);A2:C2;0))

Problème si doublon (voir comment tu les gères)

@+
 

junty94

XLDnaute Nouveau
Re : Fonction : Afficher la valeur d'une cellule adjacente ?

Bonjour junty94, bienvenue sur XLD,

voir la PJ, formule en B4.

Edit: salut Tibo :), tu commences à avoir de la concurrence...... :D lol

Merci Skoobi !

Effectivement ta solution marche aussi. La seule différence est que Tibo a directement inclus la valeur du MIN dans la fonction INDEX évitant ainsi de passer par une cellule intermédiaire..

Merci beaucoup !
 

veaf

XLDnaute Nouveau
Re : Fonction : Afficher la valeur d'une cellule adjacente ?

Bonjour à tous
J'ai à peu près la même problématique mais en un peu plus compliqué. J'ai déjà un début de solution mais il me manque une partie de la formule.
Je un tableur dans lequel il y a un top 25 par mois de mots clés. ces mots clés sont souvent les mêmes mais n'ont pas la même place dans le classement (donc ne sont pas dans sur la même ligne) je souhaite donc remplacer le "vrai" par la différence entre la valeur de la cellule situé deux colonne à droite au mois1 par rapport à la valeur de la cellule situé deux colonne à droite au mois2

Voici mon début de formule :
=SI(I9=(RECHERCHEV(I9;$B$9:$B$33;1;FAUX));"vrai";"faux")

Cette formule fonctionne. elle me trouve les valeur que je recherche. Je souhaiterai maintenant changer la valeur vrai par une soustration entre la cellule de référence (I9) et la cellule ce trouvant à droite de la cellule trouvé par la recherchev.

Merci par avance vous m'enleverai une belle épine du pied !!
 

Pièces jointes

  • Casse tête.xlsx
    12.7 KB · Affichages: 71

Discussions similaires

Statistiques des forums

Discussions
312 816
Messages
2 092 332
Membres
105 367
dernier inscrit
jych