extraire DATE … compliqué !

SSP34

XLDnaute Junior
Bonjour les Xlnautes,

Je n’ai pas trouvé de solution pour une extraction un peu (très très) compliquée.

Ma demande :

J’ai un tableau comportant les champs :
date/nom/type paiement/montant/n°bordereau/ / /copié

Est-il possible, par formule, d'extraire la première date et la dernière date d’une série de lignes en fonction d’une valeur située en colonne « copié ».

Ci-joint mon classeur avec des explications que j’espère claires.

Extrait de ma demande sur le classeur :
La formule serait : en Q5 extraire la date MIN de la plage col. A qui a pour valeur 1 en Col. K ("déjà copié"), puis la date MAX en R5
Autrement dit : pour toutes les lignes ayant la valeur 1 en col. K prendre la plus petite et la plus grande date (valeur de la col. A).

Merci à tous ceux qui voudront bien relever le défi.

Pablo.
 

Pièces jointes

  • Classeur10.zip
    18.8 KB · Affichages: 29
  • Classeur10.zip
    18.8 KB · Affichages: 29
  • Classeur10.zip
    18.8 KB · Affichages: 28

wilfried_42

XLDnaute Barbatruc
Re : extraire DATE … compliqué !

bonjour

je ne sais pas si j'ai tout compris, 2 formules matricielle, à valider avec Ctr + Shif + Enter

en Q5
Code:
=INDEX(A5:A100;MIN(SI(K5:K100=[COLOR="Red"]1[/COLOR];LIGNE(K5:K100);9^9))-4)

en R5
Code:
=INDEX(A5:A100;MAX(SI(K5:K100=[COLOR="red"]1[/COLOR];LIGNE(K5:K100);0))-4)

en rouge, j'ai mis le code à tester, on peut le remplacer de differentes facons :
en fonction du n° de ligne : Ligne()-4 (Qui donne 1 en ligne 5, 2 en ligne 6 ....)
en fonction d'une cellule de choix : exemple R1 : $R$1
en fonction de la colonne L : $L5
 

SSP34

XLDnaute Junior
Re : extraire DATE … compliqué !

Bonjour,

Merci pour ta réponse Wilfried.

Cependant (voir exemple ci-joint dans la feuille 2) si je transfère une ligne avec une date différente, et donc sur une ligne différente, j'obtions apparement toujours

le résultat de la ligne 8 c'est à dire 01/04/2008.

?

Pablo.
 

Pièces jointes

  • Classeur101.zip
    21.6 KB · Affichages: 25

wilfried_42

XLDnaute Barbatruc
Re : extraire DATE … compliqué !

re:

ton fichier en retour

meme formule, mais validée correctement comme precisé dans mon post précédent (à valider avec Ctrl, Shift, Enter)
 

Pièces jointes

  • ssp34.zip
    18.3 KB · Affichages: 31
  • ssp34.zip
    18.3 KB · Affichages: 28
  • ssp34.zip
    18.3 KB · Affichages: 27

SSP34

XLDnaute Junior
Re : extraire DATE … compliqué !

Merci Wilfried !

Je m'en suis aperçu après t'avoir répondu ... mais tu as été plus rapide.

Je savais que la solution était une formule matricielle mais il s'agit de la stratosphère pour moi.

Sans abuser (si en abusant) pourrais tu lire mon post concernant la position de la souris?
(relatif au même classeur)

Pablo
 

wilfried_42

XLDnaute Barbatruc
Re : extraire DATE … compliqué !

re:

modification de la formule
date de depart
Code:
=SI(NON(ESTERREUR(INDEX($A$5:$A$100;MIN(SI($K$5:$K$100=$L5;LIGNE($K$5:$K$100);9^9))-4)));INDEX($A$5:$A$100;MIN(SI($K$5:$K$100=$L5;LIGNE($K$5:$K$100);9^9))-4);"")

pour traiter les codes inexistants
 

Discussions similaires

Membres actuellement en ligne

Statistiques des forums

Discussions
312 872
Messages
2 093 103
Membres
105 627
dernier inscrit
jean-marc.brillant