Microsoft 365 Exploiter la nouvelle fonction RECHERCHX

Piksaw

XLDnaute Junior
Bonjour, j'ai utiliser la fonction rechercheX pour trouvé un mot présent dans la colonne de A2 à A8 et si il trouve ce mot, il m'affiche le mot qui est juste coté dans l'autre colonne.

Mais je voudrai rajouter un critère est lui dire qu'il doit rechercher deux mot different dans la colonne A2 à A8 est si un deux deux mot est trouver alors il m'affiche la correspondance qui est juste a coté. ça fait une heure que je retourne la formule dans tout les sens avec des SI mais impossible si quelqu'un aurai une idée je suis preneur :)
 

Etoto

XLDnaute Barbatruc
Bonjour, j'ai utiliser la fonction rechercheX pour trouvé un mot présent dans la colonne de A2 à A8 et si il trouve ce mot, il m'affiche le mot qui est juste coté dans l'autre colonne.

Mais je voudrai rajouter un critère est lui dire qu'il doit rechercher deux mot different dans la colonne A2 à A8 est si un deux deux mot est trouver alors il m'affiche la correspondance qui est juste a coté. ça fait une heure que je retourne la formule dans tout les sens avec des SI mais impossible si quelqu'un aurai une idée je suis preneur :)
Hello,

En fait, le mieux serait de faire deux RECHERCHEX et de dire que si celui-ci et celui-ci renvoient une valeur, il affiche la correspondance d'a coté, mais comme dit JHA, sans fichier, c'est la seule explication que je peux te donner.
 
Dernière édition:

Piksaw

XLDnaute Junior
Hello a tous

voila le fichier en question, vous pouvez sans autre regarder les formule que j'ai mis dans le planning journalier, si vous voyez que l'on peut simplifier les formule :) j'ai essayer de faire au mieux avec mes petite connaissances

pour résumer un peu le fichier quand un chantier est en cours, selon la date, il passe en orange et l'adresse vient se coller directement a coter du prénom de la personne concernée, quand il est terminer il passe en vert et la chose que je n'arrive pas a faire c'est que quand c'est un nouveau chantier qui va commencer le lendemain il est en bleu avec une forme conditionnel, jusque là c'est ok, mais c'est écrit nouveau au lieu de en cours et ensuite le jours suivant il passera en cours en orange mais comme ça on sait que les chantier en bleu il faut préparer une fiche de travail car c'est un nouveau chantier qui va commencer

le soucis 'est que la fonction recherche devrait chercher le mot en cours et le mot nouveau si un des deux est trouver il copie l'adresse du chantier.
 

Pièces jointes

  • Planning.xlsm
    91.2 KB · Affichages: 13

Etoto

XLDnaute Barbatruc
Hello a tous

voila le fichier en question, vous pouvez sans autre regarder les formule que j'ai mis dans le planning journalier, si vous voyez que l'on peut simplifier les formule :) j'ai essayer de faire au mieux avec mes petite connaissances

pour résumer un peu le fichier quand un chantier est en cours, selon la date, il passe en orange et l'adresse vient se coller directement a coter du prénom de la personne concernée, quand il est terminer il passe en vert et la chose que je n'arrive pas a faire c'est que quand c'est un nouveau chantier qui va commencer le lendemain il est en bleu avec une forme conditionnel, jusque là c'est ok, mais c'est écrit nouveau au lieu de en cours et ensuite le jours suivant il passera en cours en orange mais comme ça on sait que les chantier en bleu il faut préparer une fiche de travail car c'est un nouveau chantier qui va commencer

le soucis 'est que la fonction recherche devrait chercher le mot en cours et le mot nouveau si un des deux est trouver il copie l'adresse du chantier.
Hello,

Formule pour afficher "nouveau" :
VB:
=SI(J36>AUJOURDHUI();"nouveau";SI(J36="";"";SI(J36=Journalier!$C$2;"en cours";SI(J36>AUJOURDHUI();"";SI(K36<=AUJOURDHUI();"terminé";SI(J36<=AUJOURDHUI();"en cours"))))))

Formule pour la MFC bleu :
Code:
=$D7:$D57="nouveau"

Et voici le fichier.
 

Pièces jointes

  • Planning.xlsm
    87.8 KB · Affichages: 13

Piksaw

XLDnaute Junior
Hello,

Formule pour afficher "nouveau" :
VB:
=SI(J36>AUJOURDHUI();"nouveau";SI(J36="";"";SI(J36=Journalier!$C$2;"en cours";SI(J36>AUJOURDHUI();"";SI(K36<=AUJOURDHUI();"terminé";SI(J36<=AUJOURDHUI();"en cours"))))))

Formule pour la MFC bleu :
Code:
=$D7:$D57="nouveau"

Et voici le fichier.
Hello ,

merci pour ta réponse, enfaite cette partie la j'avais réussi, je me suis mal exprimer, c'est la suite qui pose soucis il faudrai qu'il me copie l'adresse dans planning journalier si c'est écrit en cours avec une fonction recherchex ça fonctionne, mais uniquement si il doit chercher juste le mot en cours, mais du moment ou il doit en chercher deux ( en cours ) et ( nouveau ) si il en trouve un des deux il copie la ligne adresse, c'est la que ça coince
 

Etoto

XLDnaute Barbatruc
Hello ,

merci pour ta réponse, enfaite cette partie la j'avais réussi, je me suis mal exprimer, c'est la suite qui pose soucis il faudrai qu'il me copie l'adresse dans planning journalier si c'est écrit en cours avec une fonction recherchex ça fonctionne, mais uniquement si il doit chercher juste le mot en cours, mais du moment ou il doit en chercher deux ( en cours ) et ( nouveau ) si il en trouve un des deux il copie la ligne adresse, c'est la que ça coince
Honnêtement, tu as imbrique tellement de SI que je suis perdu ! Je verrais cela se soir sur Excel 365.

Et je suis Barbatruc !!!!
 

Discussions similaires

Statistiques des forums

Discussions
312 816
Messages
2 092 331
Membres
105 367
dernier inscrit
jych