Erreur quelque part...

Clochard

XLDnaute Impliqué
Bonjour le Forum,

J'aimerais bien avoir recours à votre aide S.V.P

J'arrive pas à obtenir l'info demandée par mes formules...

Je joins un fichier pour une meilleure compréhension....

Merci d'y regarder

Clochard
 

Pièces jointes

  • Test 1 Clochard.xls
    33 KB · Affichages: 52
  • Test 1 Clochard.xls
    33 KB · Affichages: 65
  • Test 1 Clochard.xls
    33 KB · Affichages: 64

Grand Chaman Excel

XLDnaute Impliqué
Re : Erreur quelque part...

Bonjour Clochard,
J'ai regardé rapidement... Le problème semble venir de la valeur "20" en cellule F2.
Probablement parce que tu as 3 lignes vides entre A1 :A5.
Remplace ta formule en F2 par "=NBVAL($A:$A)+3" et ça semble fonctionner.

A essayer
 

hbenalia

XLDnaute Occasionnel
Re : Erreur quelque part...

Bonjour à tous,

Un essai avec le fichier attaché. Les formules des colonnes F et H ont été changées en formules plus réduites.

Cordialement
 

Pièces jointes

  • Test 1 Clochard.xls
    38 KB · Affichages: 48
  • Test 1 Clochard.xls
    38 KB · Affichages: 55
  • Test 1 Clochard.xls
    38 KB · Affichages: 58

Clochard

XLDnaute Impliqué
Re : Erreur quelque part...

Bonjour le Forum,

Petit problème que j'arrive pas a formuler....

Avec la formule suggérée par Hbenalia dans le fichier joint... si dans la cellule E4 il n'y a pas de nom... toute la liste de mes noms s'affiche

Merci d'y regarder

Clochard
 

Pièces jointes

  • Test 1 Clochard.xls
    32.5 KB · Affichages: 29
  • Test 1 Clochard.xls
    32.5 KB · Affichages: 30
  • Test 1 Clochard.xls
    32.5 KB · Affichages: 24
Dernière édition:

Dull

XLDnaute Barbatruc
Re : Erreur quelque part...

Salut Clochard, GCE, hbenalia, le Forum

Ajoute, si j'ai bien compris, une gestion de vide en E4

Code:
=SI(E$4="";"";SI(LIGNES($G$5:$G5)<=NB(CHERCHE(BD!$E$4;phr));INDEX(phr;PETITE.VALEUR(SI(ESTNUM(CHERCHE(BD!$E$4;phr));LIGNE(INDIRECT("1:"&LIGNES(phr))));LIGNES($G$5:$G5)));""))

en Matricielle bien sur

Bonne Journée
 

Clochard

XLDnaute Impliqué
Re : Erreur quelque part...

Merci Dull,

Malheureusement j'arrive pas à l'appliquer dans mon dossier... ça fonctionne sur mon fichier "Test" mais pas dans mon vrai fichier...
J'avais déjà tenté d'ajouter cette gestion de vide =(E4="";"";..... mais ça me donne une erreur sur la formule que j'arrive pas a gérer....

Merci et bonne journée

Clochard
 

Discussions similaires

Statistiques des forums

Discussions
312 801
Messages
2 092 245
Membres
105 314
dernier inscrit
SABER ABD