enlever les case vide grace a une formule

Mr Guizz

XLDnaute Junior
Salut a tous !
J'aimerai trouvé une formule ( j'insiste sur le fait que je veux absolument une formule) qui me permettrait de supprimer les case vides d'une liste . Voici un exemple pour mieux m'expliquer

Partons de cette liste (A1:F1)
A Toto
B Tata
C
D Titi
E
F Tutu

Resultat attendu (en H1:M1)
H Toto
I Tata
J Titi
K Tutu
L
M

Je sais qu'il est possible de le faire avec les filtres mais j'aimerai aussi avoir une solution avec une formule!
Merci pour votre aide
 

Modeste

XLDnaute Barbatruc
Bonjour Mr Guizz,
Salut JBOBO :)

Une autre solution pour H1:
Code:
=SIERREUR(INDEX($A$1:$A$30;PETITE.VALEUR(SI($A$1:$A$30<>"";LIGNE($A$1:$A$30));LIGNES($1:1)));"")
Valider avec Ctrl+Shift+Enter

[Edit:] Salut JHA :)
[Edit bis:] avec la plage de départ en A1:F1, il faut plutôt utiliser:
Code:
=SIERREUR(INDEX($A$1:$F$1;PETITE.VALEUR(SI($A$1:$F$1<>"";COLONNE($A$1:$F$1));LIGNES($1:1)));"")
 
Dernière édition:

Mr Guizz

XLDnaute Junior
Merci pour vos reponse !
Du coup je joint un fichier pour vous montrer reelement ce que je veux ! (resultat a la verticale )
( cela dit , j'ai juste a adapter l'horizontal avec la verticale!)
merci

[EDIT]
( cela dit , j'ai juste a adapter l'horizontal avec la verticale!) euh.... en fait ca a pas l'air si simple que ca .....
 

Pièces jointes

  • case vide.xlsx
    9.2 KB · Affichages: 44
Dernière édition:

Discussions similaires

Membres actuellement en ligne

Statistiques des forums

Discussions
312 913
Messages
2 093 535
Membres
105 752
dernier inscrit
fred13340