XL 2019 Deux conditions avec calcul matriciel

Chubby

XLDnaute Impliqué
Bonjour le forum,

Petit problème du jour. Je reprends des données d'un onglet selon trois critères (deux en ligne et un en colonne). Merci à Sylvanu, JHA et Patricktoulon pour m'avoir aidé en ce problème. Ca s'applique alors à un critère en colonne (mill), mais j'aimerais aller plus loin en calculant la moyenne sur une durée lorsque ça s'impose (présence de deux critères mill)
Je ne sais pas si je suis très clair .... donc petit tableau exemple joint.
Merci d'avance
 

Pièces jointes

  • Deux conditions.xlsx
    14.5 KB · Affichages: 10

AtTheOne

XLDnaute Accro
Supporter XLD
Bonjour @Chubby, bonjour à tous

J'ai ajouté 3 noms définis pour raccourcir les formules...

Et les 3 formules suivantes :
  • =SIERREUR(ARRONDI.AU.MULTIPLE(MOYENNE.SI.ENS(
    INDEX(TabFrance;EQUIV($B6&$C6;INDEX(Tb_F;;1)&INDEX(Tb_F;;2);0););
    LigneMill;SI($D$5="";"";">=")&$D$4;
    LigneMill;SI($D$5="";"<>";"<="&$D$5));100);0)
  • =SIERREUR(ARRONDI.AU.MULTIPLE(MOYENNE.SI.ENS(
    INDEX(TabExport;EQUIV($B6&$C6;INDEX(Tb_E;;1)&INDEX(Tb_E;;2);0););
    LigneMill;SI($E$5="";"";">=")&$E$4;
    LigneMill;SI($E$5="";"<>";"<="&$E$5));100);0)
  • =SIERREUR(ARRONDI.AU.MULTIPLE(MOYENNE.SI.ENS(
    INDEX(TabFranceExport;EQUIV($B6&$C6;INDEX(Tb_FE;;1)&INDEX(Tb_FE;;2);0););
    LigneMill;SI($F$5="";"";">=")&$F$4;
    LigneMill;SI($F$5="";"<>";"<="&$F$5));100);0)


Voir PJ
Bonne journée
Alain
 

Pièces jointes

  • Deux conditions.xlsx
    16.3 KB · Affichages: 4

Chubby

XLDnaute Impliqué
Bonjour AtTheOne,

Ben voilà qui est simple et qui marche. Bravo d'avoir déchiffré ma demande et bravo d'y avoir répondu parfaitement.
Je vais me pencher dessus pour comprendre un peu tout ça.
Merci Alain.
 
Dernière édition:

Discussions similaires

Statistiques des forums

Discussions
312 801
Messages
2 092 245
Membres
105 314
dernier inscrit
SABER ABD