Microsoft 365 définir une liste "à pourvoir" et une autre "en retard"

Guesh

XLDnaute Occasionnel
Bonjour le Forum !

J'ai un tableau que je souhaiterais "interroger"
En Feuil 1 de la colonne I à BM j'ai un prévisionnel de mobilisation dans le temps ("1" correspond à une présence supposée et un "1" qui suit un "0" suppose un démarrage).
A noter que lorsque le Titre (colonne E) est pourvu, il y a une date de démarrage indiquée en colonne G.

Je souhaiterais donc pouvoir interroger ce tableau pour qu'il me sorte 2 listes (cf Feuil 2 : Tableaux A et B)

Pour le tableau A : les Titres à pouvoir dans les 8 prochains mois (incluant le mois en cours. Ici Jun-22 par exple)
Pour le Tableau B : lister les Titres non pourvus et en retard car antérieurs au mois en cours (ici antérieurs à Juin 22)

Les "Titres" remontés en tableaux A et B ne doivent est remontés uniquement si la cellule start (Feuil1 colonne G) est vide.

J'aimerais me passer de macros. Est-ce possible via des formules ?

merci beaucoup pour l'aide

Gsh
 

Pièces jointes

  • Test A .xlsx
    23.9 KB · Affichages: 5

JHA

XLDnaute Barbatruc
Bonjour à tous,

Je ne comprends pas le planning de la feuille 1 car les formules ne sont pas correctes. J'ai mis un début de formule mais je ne sais pas si cela est correct.

Peux-tu nous éclairer avant de se pencher sur les deux autres tableaux?

JHA
 

Pièces jointes

  • Test A .xlsx
    21.6 KB · Affichages: 0

Guesh

XLDnaute Occasionnel
Bonjour à tous,

Je ne comprends pas le planning de la feuille 1 car les formules ne sont pas correctes. J'ai mis un début de formule mais je ne sais pas si cela est correct.

Peux-tu nous éclairer avant de se pencher sur les deux autres tableaux?

JHA
Bonjour JHA,

désolé pour ce mauvais copier-coller
en PJ les valeurs en question

merci !
 

Pièces jointes

  • Test A .xlsx
    22 KB · Affichages: 1

JHA

XLDnaute Barbatruc
Bonjour à tous,

Je t'avoue ne pas comprendre le sujet des tableaux en "Feuille 2".

Ci joint une formule pour trouver les dates de démarrage en colonne "BO" de la feuille 1.

VB:
=SIERREUR(DECALER($H$1;;EQUIV(1;($J2:$BM2=1)*($I2:$BL2=0);0)+1);$G2)

et une formule pour trouver la date dans 8 mois.

Code:
=MOIS.DECALER(AUJOURDHUI();$I$1)

J'espère que cela te fera avancer dans ton projet.

JHA
 

Pièces jointes

  • Test A (3).xlsx
    24.3 KB · Affichages: 1

Discussions similaires

Statistiques des forums

Discussions
312 928
Messages
2 093 697
Membres
105 787
dernier inscrit
BABOU79