Définir jours de congé

Lipadec

XLDnaute Occasionnel
Bonjour le Forum et bon Dimanche pour tout le monde

Voici quatre jours que je me débat avec une formule qui va me résoudre un problème.
Je veux mentionner sur le bulletin de paie de mes employés, le nombre de jours de congé payé, des jours pris et des jours qui restent, en fonction de la date de paie,qui est la fin de chaque mois.
J"ai voulu joindre un fichier, mais vu que les formules sont longues, le fichier dépasse le volume autorisé.
Mais voici les formules
Col A=mois décembre
Col B=N° 48
Col C=date d"embauche 17/5/2012
Col D=date de paie 31/12/2012

Col E=ancienneté =SI(ESTERREUR(DATEDIF(C2;D2;"y")&" a "&DATEDIF(C2;D2;"ym")&" m "&DATEDIF(C2;D2;"md")&" j ");"";DATEDIF(C2;D2;"y")&" a "&DATEDIF(C2;D2;"ym")&" m "&DATEDIF(C2;D2;"md")&" j ")

Col F=congé dû =ARRONDI.SUP(SI((D2-C2)/365>=22,5;21;SI((D2-C2)/365>=15;22,5;SI((D2-C2)/365>=10;21;SI((D2-C2)/365>=5;19,5;SI((D2-C2)/365<5;18;""))))/12*MOIS(D2));0)

cette formule me donne 18, or 'est faux.

Pouvez-vous m'aider, car je sais que rien n'est impossible chez mes amis du Forum.
Merci d'avance

Lipadec
 
Dernière édition:

JCGL

XLDnaute Barbatruc
Re : Définir jours de congé

Bonjour à tous,

Tu divises par 365 la différence entre la date d'embauche et la date de fin d'année...
Si je comprends ta demande, il faut diviser la présence par 365 ET multiplier par le nombre de jour dont aurait bénéficié l'ouvrier si il avait travaillé 365 jours (ici je suppose 25 jours pour une année entière) :
Code:
=ARRONDI.SUP((D2-C2);5)/365*25

A + à tous
 

Lipadec

XLDnaute Occasionnel
Re : Définir jours de congé

Re

C'est le résultat affiché à la colonne F de mon fichier exemple. Le résultat est bon quand l'ancienneté dépasse 365j. Mais quand c'est moins, le résultat est faux.
Veuillez vérifier SVP
Merci
 

Discussions similaires

Statistiques des forums

Discussions
312 885
Messages
2 093 256
Membres
105 658
dernier inscrit
Mario Richard