XL 2016 Date dans formule somme si

Msouami33

XLDnaute Nouveau
Bonjour,

j'ai une date qui se trouve en cellule H1, quand je fais ma formule si avec le critère >=h1, cela ne marche pas alors que quand je met directement la date <=10/10/2021 la somme si marche. Mais comme je voudrais automatiser mon fichier, je voudrais que ca marche direct avec la cellule, d'ailleurs mes fonctions SI marche avec la cellule voir exemple ci dessous
 

Pièces jointes

  • Exemple.xlsx
    15.1 KB · Affichages: 6

Msouami33

XLDnaute Nouveau
En fait la fonction Si marche, c'etait la fonction somme si qui ne marchait pas. mais j'ai vu qu'il fallait mettre "<=" & H1. Alors je ne sais pas pourquoi il faut rajouter un espace et un & dans la formule sommesi mais ca marche, merci à vous
 

Hasco

XLDnaute Barbatruc
Alors je ne sais pas pourquoi il faut rajouter un espace et un & dans la formule sommesi mais ca marche, merci à vous
bonjour,
Dans :
=SOMME.SI(B2: D4;"<=" & $H$1;D2: D4)
L'espace n'est pas obligatoire.
Si vous mettez "<=H1" ou "<=$H$1" excel va comparer les cellules à sommer avec la chaîne de caractère "H1" ou "$H$1" alors que si vous mettez "<="& $H$1 excel comparera les cellules à sommer avec la valeur de $H$1 (la date dans votre exemple).

Cordialement
 
Dernière édition:

Statistiques des forums

Discussions
299 706
Messages
1 978 625
Membres
206 312
dernier inscrit
dameli70