Microsoft 365 Création d'une occurrence avec lignes vides

kawi99

XLDnaute Junior
Bonjour à tous !
Me revoilà car je cale sur une formule (ou plusieurs).
Je vais essayer d'être clair ...

J'ai des personnes qui ont passé des formations dont certaines sont regroupées sous le même intitulé (colonne AI).
Du coup, je cherche à créer une formule qui tient compte de ces regroupements.

Je m'explique par rapport au fichier joint sur ce qu'il me faut :
PIERRE à eu 7 formations (colonne AM, ça c'est pas dur ;) ), regroupées en 4 intitulés (colonne AO ou AP dans mes tests)
1 - Circuit découverte (Intégration) Module 1 : 1 formation, 3h
2 - Les bases de la gestion de projet chez CF :1 formation, 3h
3 - Parcours d'intégration : 3 formations, 6.15h
4 - Parcours Maîtrise de risque : 2 formations, 2.55h

PAUL à eu 9 formations, regroupées en 3 intitulés
1 - OnBase Unity : 1 formation, 4h
2 - Parcours Maîtrise de risque : 3 formations, 4.9h
3 - Parcours Philosophie de gestion : 5 formations, 4h

JACQUES à eu 8 formations, regroupées en 6 intitulés
1 - Certification Finance Durable : 1 formation, 1.5h
2 - La gestion de projet (Niveau 2) : 1 formation, 3h
3 - Les bonnes pratiques du télétravail pour tous : 1 formation, 1h
4 - Manipulation d'extincteur : 1 formation, 1.5h
5 - Parcours Maîtrise de risque : 1 formation, 0.5h
6 - Parcours Philosophie de gestion : 3 formations, 9h

C'est possible ?

Merci par avance et bonne journée à tous !
 

Pièces jointes

  • Excl Dwld.xlsx
    21.8 KB · Affichages: 4

kawi99

XLDnaute Junior
Re-bonjour et merci pour vos retours !

Comme prévu, je n'ai pas été clair :D
Je vous rejoins un tableau ou j'ai forcé les colonnes AN, AO et AP avec les résultats attendus.
AN : Numéro formations regroupées
AO : Nombre de formation (regroupement par intitulé)
AP : Nombre d'heures effectuées par intitulé (regroupement)

N'hésitez pas si je ne suis toujours pas clair !

Encore merci, Kawi
 

Pièces jointes

  • Excl Dwld.xlsx
    19.7 KB · Affichages: 3

sylvanu

XLDnaute Barbatruc
Supporter XLD
Re,
Avec une colonne supplémentaire cachée ( colonne AN ) avec :
VB:
=SI(NB.SI.ENS($E$5:E5;E5;$AI$5:AI5;AI5)<>1;"";E5)
et en colonnes :
Code:
AO  :  =SI(AN5="";"";NB.SI($AN$5:AN5;E5))
AP  :  =SI(AN5<>"";NB.SI.ENS($E$5:$E$35;E5;$AI$5:$AI$35;AI5);"")
AQ  :  =SI(AN5<>"";SOMME.SI.ENS($Y$5:$Y$35;$E$5:$E$35;E5;$AI$5:$AI$35;AI5);"")
Le tableau Vert n'est là que pour tester vis à vis de l'attendu. ( à supprimer )
 

Pièces jointes

  • Excl Dwld (V2).xlsx
    22.9 KB · Affichages: 2

kawi99

XLDnaute Junior
Merci Sylvanu, c'est top !!
Seul bémol, la colonne cachée envoie vers les noms mais j'ai des homonymes...
J'ai testé avec les matricules mais ça ne renvoie rien (colonne AO vide) !?
Comment puis-je solutionner ça ?
Merci
 

Discussions similaires

Statistiques des forums

Discussions
313 197
Messages
2 096 115
Membres
106 501
dernier inscrit
axtion