Condition "SI" entre 2 feuilles

Janot95

XLDnaute Nouveau
Bonjour,

Une formule qui ne fonctionne pas !
Soit la condition suivante:
Feuil1 _en A1 : Saisie de : "x" ou " " (vide)
_en B1 : Formule : =SI(A1="x";0;'feuil2'!$H$1)
====
Feuil2 _en H1 = 10.00€ ' <== valeur à retourner en feuil1 (Cette valeur est le résultat d'une autre formule)

A noter; pas d'erreur avec cette petite formule, mais retourne "0.00€" en B1 que A1 soit vide ou pas !
Qu'elle est la raison de ce problème ?

Quelqu'un aurait-il une idée ?
Merci.
Cdt, JF
 

Janot95

XLDnaute Nouveau
ah bah pas de fichier, car trop simple...
Oui, effectivement A1 est vide ou contient "x"...

Le problème vient de la condition...
Car si je ne mets pas de condition, la valeur de "H1" de la feuil2 est correctement retournée...
Ça, c'est du genre classique comme lien...
Mais dès qu'il y a la condition... plus rien !?!
 

Dugenou

XLDnaute Barbatruc
bah oui trop simple : la preuve : ça marche dans la pj
donc y'a autre chose que ce que tu nous dis et pour le voir, nous n'avons pas de boule de cristal. A défaut une petite partie de ton fichier serait utile
Cordialement
 

Pièces jointes

  • janot95.xlsx
    9.1 KB · Affichages: 37

Janot95

XLDnaute Nouveau
Ah ! Je suis désolé... je devais être très fatigué...
En effet, ma formule fonctionne très bien ! (si simple !)
Mais je m'étais simplement trompé de "cible" (ici "H1") !!!
C'est en reproduisant cette formule dans un p'tit fichier que je m'en suis rendu compte !
Quel idiot !
Alors merci quand même à Dugenou et JHA de s'être intéressés à mon sujet...
Je tacherai de faire mieux la prochaine fois...

Cordialement
JF
 

Discussions similaires

Réponses
4
Affichages
406

Statistiques des forums

Discussions
312 801
Messages
2 092 245
Membres
105 313
dernier inscrit
tissouma