COmpteur de nombre entier pour une mois spécifié

  • Initiateur de la discussion XGuarden
  • Date de début
X

XGuarden

Guest
Dan la colonne A, mois d'inscrit
Dans la colonne B j'ai des nombre.
Je veut compter dans le nombre d'enregistrement ENTIER dans la colonne b selon un mois spécifié.
Merci d'avance
 
X

XGuarden

Guest
Petit exemple poue etre plus clair.


A B
janvier 16
février 13
janvier 123.1
janvier 6
janvier 17.2
février 12.5



Nombre de nombre entier pour le mois de janvier: 2
Nombre de nombre entier pour le mois de février: 1


C'est juste sa, si je ne me trompe pas, c'Est possible avec MOD.
Noublier pas que je ne peut pas utiliser de macro...
 

Gael

XLDnaute Barbatruc
Bonsoir Xguarden,

Si un nombre est entier, son arrondi avec la fonction ENT est égal à lui-même.

Avec ce principe et SOMMEPROD on peut par exemple écrire (avec les mois en A1:A8 et les chiffres en B1:B8:

=SOMMEPROD((A1:A8='Janvier')*(ENT(B1:B8)=B1:B8)*1)

cela donnera le nombre de cellules Janvier en colonne A avec un nombre entier en colonne B.

@+

Gael

PS: Pour la prochaine fois, n'oublie pas de lire la charte du forum, de saluer en début de message et d'envoyer un petit merci si la solution fonctionne.
 
X

XGuarden

Guest
Merci, sa regle une bonne partie de mon probleme. J'avais penser a arondir a un moment donnée mais je trouvais qua avait aucun lien. J'ai jamasi penser a comparer le résultat de l'arondissement. JE suis stupide....
Entuqua sa vaut mieux que la formule que j'avais réalisé:
=SI($A1<10;SI(NBCAR($A1)=1;1;0);SI($A1<100;SI($A1>9;SI(NBCAR($A1)=2;1;0);SI($A1<1000;SI($A1>99;SI(NBCAR($A1)=3;1;0);0);0));0))
+ un nb.si apres lol
 

Monique

Nous a quitté
Repose en paix
Bonjour,

Avec la fonction Mod() à laquelle tu avais pensé :
=SOMMEPROD((A1:A8='Janvier')*(MOD(B1:B8;1)=0))

Si tu risques d'avoir des cellules vides en colonne B :
=SOMMEPROD((A1:A8='Janvier')*(MOD(B1:B8;1)=0)*(B1:B8<>''))
 

Monique

Nous a quitté
Repose en paix
Bonjour,

ça doit être du pareil au même.
mais tu n'en as que 12, non ?
Par sécurité, tu prends celle qui contient le moins souvent la plage A1:A10000, donc Mod()
Mais tu peux aussi faire un essai.

Si c'est lourd et lent, tu peux donner un nom à ta formule
(Insertion - Nom - Définir -
en haut, tu tapes le nom choisi,
en bas, tu tapes la formule)
Nommer une formule allège le fichier et, assez souvent, accélère le recalcul.
 

Statistiques des forums

Discussions
312 947
Messages
2 093 835
Membres
105 848
dernier inscrit
toooom