Compter les ocurrences

jkv

XLDnaute Junior
Bonjour le forum,
Je revienss à vous pour demander de l'aide concernant deux problèmes: une addition d'ocurrences et une extraction des lettres avec conditions.

Le fichier joint contient le détail de ma demande.

Avec mes plus sincères remerciements
jkv
 

Pièces jointes

  • CompteOcurrences.zip
    6.3 KB · Affichages: 23

Cousinhub

XLDnaute Barbatruc
Re : Compter les ocurrences

Bonjour,
si tu veux garder ton exemple en B14: D16, et avoir les résultats en G14:I16,
tu peux mettre cette formule en G14, et tirer vers la droite et vers le bas

Code:
=SI(NB.SI($B$8:$V$10;B14)=0;"K";NB.SI($B$8:$V$10;B14))

Sinon, tu remplaces la référence aux cellules par les chiffres :

Code:
=SI(NB.SI($B$8:$V$10;1)=0;"K";NB.SI($B$8:$V$10;1))
=SI(NB.SI($B$8:$V$10;2)=0;"K";NB.SI($B$8:$V$10;2))
.....
 

jkv

XLDnaute Junior
Re : Compter les ocurrences

Re le forum, bhbh, Denis,
Merci à vous deux. Pour le calcul de la grille je prend les formules de bhbh, elles sont plus courtes et plus simples. Pour les voyelles je prend celles de Denise. Merci encore
 

jkv

XLDnaute Junior
Re : Compter les ocurrences

Re le forum, bhbh, Denis,
Denis: j'ai essayé tes formules pour les voyellles mais il y a un problème. En fait, elles calculent la première lettre du prénom et la dernière lettre du nom mais pas forcement la première et la dernière voyelle.
Merci de vos réponses.
 

Cousinhub

XLDnaute Barbatruc
Re : Compter les ocurrences

Re-,
Excuse, j'avais pas vu le 2 ème problème

regarde le fichier joint

la formule pour la première voyelle (formule matricielle, à valider par Ctrl + Maj + Entrée :

Code:
=INDEX(B9:V9;1;MIN(SI(B8:V8<>"";COLONNE(B8:V8)))-1)

et pour la dernière, la même, mais avec Max
 

Pièces jointes

  • CompteOcurrences_v1.zip
    9.2 KB · Affichages: 18

Denis132

XLDnaute Impliqué
Re : Compter les ocurrences

Bonjour jkv, bhbh,

jkv, j'aurais dû te spécifier que j'avais modifié ta formule:=SI(OU(B9={"A";"E";"I";"O";"U";"Y";"é";"è";"ê";"ç";"û";"ü";"î";"ë";"ô";"ö";"à";"â"});RECHERCHEV(B9;$X$1:$Y$38;2;FAUX);0). J'ai mis 0 à la place de "" à la fin.

De cette façon, cela fonctionne, par contre la formule de bhbh est beaucoup moins longue.

@+

Denis
 

Discussions similaires

Réponses
2
Affichages
178

Membres actuellement en ligne

Statistiques des forums

Discussions
312 084
Messages
2 085 194
Membres
102 813
dernier inscrit
kaiyi