Comparer deux feuilles sur un fichier

franxy

XLDnaute Junior
Bonjour,

J'ai bien essayé de trouver avec les formules recherch, si, nb.si ou la derniere nb.si.ens mais bof c'est pas le top

En fait j'ai un fichier avec deux feuilles, une RUE, une Inventaire

Il me faut savoir dans la feuille inventaire si toutes les rues de la feuille Rue ont été visitées

Il me faut savoir aussi si dans la feuille Inventaire, une rue supplémentaire de la feuille rue a été visitée.

Qq a une idée ?

Merci
 

Pièces jointes

  • Exemple.xlsx
    11.7 KB · Affichages: 38
  • Exemple.xlsx
    11.7 KB · Affichages: 39
  • Exemple.xlsx
    11.7 KB · Affichages: 34
Dernière édition:

Modeste

XLDnaute Barbatruc
Re : Comparer deux feuilles sur un fichier

Bonsoir franxy,

Avec ce que j'ai cru comprendre, teste en D2 de la feuille "Inventaire"
Code:
=SI(ESTNUM(EQUIV(A2&B2;Rue!$A$2:$A$10&Rue!$B$2:$B$10;0));"";"pas trouvé")
Formule matricielle, à valider à l'aide de Ctrl+Shift+Enter, puis recopier vers le bas
 

franxy

XLDnaute Junior
Re : Comparer deux feuilles sur un fichier

En fait si je mets cette formule qui ressemble certes à la tienne,
=SI(EQUIV(Inventaire!B2;Rue!$B$2:$B$10;0);"trouvé";"pas trouvé") sauf que je trouve des #N/A sans explication... Une idée ?
 

Pièces jointes

  • Exemple.xlsx
    12.7 KB · Affichages: 34
  • Exemple.xlsx
    12.7 KB · Affichages: 34
  • Exemple.xlsx
    12.7 KB · Affichages: 36

Modeste

XLDnaute Barbatruc
Re : Comparer deux feuilles sur un fichier

Re-bonsoir,

Ta dernière formule permet de savoir si une rue présente dans la feuille "Inventaire" existe aussi dans la feuille "Rue" ... mais il me semble que tu pourrais avoir dans "Rue" une rue du Midi à Lyon, alors qu'une rue du Midi serait renseignée en feuille "Inventaire", mais pour Marseille.
La formule que j'ai proposée vérifie l'existence de la paire ville/rue dans les deux feuilles. En dehors de ça, je ne vois pas trop ce que tu veux que j'explique ... :confused: et puis il est l'heure de sortir le chine, puis d'aller mettre mon avant-dernier neurone au lit, de toute manière :rolleyes:

A demain donc, pour ma part, mais bienvenue aux noctambules de passage :)
 

Discussions similaires

Statistiques des forums

Discussions
312 947
Messages
2 093 837
Membres
105 850
dernier inscrit
mat.prv