Comment faire??????

  • Initiateur de la discussion Nadine
  • Date de début
N

Nadine

Guest
Bonjour
Gros problème pour moi.
J'ai 3 lignes A1,B1,C1, des calculs apparaissent en A1 et en B1 .La ligne C1 doit additionner C1+A1 si les valeurs sont dans A1 ou doit soustraire C1-B1 si les valeurs sont dans B1.Il faut savoir que soit j'ai une valeur dans A1 soit dans B1 mais jameis dans les 2 cellules à la fois.
J'ai voulu résoudre mon problème avec une formule du genre:
Si(A1>1;C1+A1;si(B1>1;B1-C1)) mais cela ne marche pas.
Quelqu'un pourrait il m'aider soit avec une formulle excel ou un code VBA
Merci pour toutes les réponses
A+ Nadine
 
T

Ti

Guest
je ne comprends pas bien, tu ne peux pas, dans C1, faire un calcul du genre A1+C1 sinon tu crées une erreur (référence circulaire). Maintenant, si ta formule doit être placée ailleurs que dans C1 (dans D1 par ex. ), alors ta formule dans D1 sera la suivante :

=SI(A1<>"";C1+A1;C1-B1)
 
C

chris

Guest
D'accord avec Ti sur la référence circulaire mais si soit A soit B est vide, il vaut 0 donc le test est inutile. Comme je l'ai dit il suffit de mettre
+A1-B1+C1
Sur un très gros tableau les tests inutiles peuvent ralentir les temps de calcul.
Chris
 

Discussions similaires

Statistiques des forums

Discussions
299 845
Messages
1 979 503
Membres
206 753
dernier inscrit
mounir311