Comment combiner RECHERCHEV avec SI ou autre fonction pour trouver la valeur correspo

vavafufu

XLDnaute Nouveau
Bonjour

Est-ce que vous savez comment on peut trouver la valeur correspondante (Tx.act-tabl.2) à un intervalle des dates ayant une référence commune comme dans l’exemple qui suit :

Tabl.1
No ID Début Fin Tx Act
587 01/09/2007 16/02/2008 75
587 17/02/2008 11/05/2008 75
587 12/05/2008 30/08/2008 100
587 31/08/2008 13/07/2009 100
592 01/09/2007 16/02/2008 50
592 17/02/2008 15/03/2008 50
592 16/03/2008 16/07/2008 25
592 17/07/2008 30/08/2008 25


Tabl.2
No ID Date Tx Act.
587 30/01/2008
587 21/04/2008
587 02/11/2007
587 02/11/2007
587 20/12/2007
592 07/09/2007
592 04/12/2007
592 08/03/2008
592 23/06/2009

Merci à l’avance pour votre aide
 
G

Guest

Guest
Re : Comment combiner RECHERCHEV avec SI ou autre fonction pour trouver la valeur cor

bonjour,

Avec Tabl.1 en A1 et Tabl.2 en G2:

I2 =SOMMEPROD(($G2=$A$2:$A$9)*($H2>=$B$2:$B$9)*($H2<=$C$2:$C$9)*$D$2:$D$9)

A tirer vers le bas
 

Discussions similaires

Réponses
2
Affichages
602

Membres actuellement en ligne

Statistiques des forums

Discussions
313 329
Messages
2 097 235
Membres
106 883
dernier inscrit
Papalo