chiffres communs sur 2 plages

J

JJ1

Guest
Bonjour,
Je voudrais connaître le nombre de chiffres communs sur 2 plages de chiffres:
ex:
plage 1: 2 10 5 4 6
plage 2: 3 5 11 15 2
renverrait 2 car il y a le 2 et 5 communs
Une combinaison de sommeprod et nb.si?
Merci

Bonne journée
 

abcd

XLDnaute Barbatruc
Re : chiffres communs sur 2 plages

Bonjour,

Les valeurs en A1:E2

Cette formule n'accepte pas les cellules vides, bien du texte.
=NB.SI(A1:E2;"<>""")-SOMMEPROD(1/NB.SI(A1:E2;A1:E2))

Cette formule n'accepte pas du texte, bien les cellules vides
=NB.SI(A1:E2;"<>""")-SOMMEPROD((FREQUENCE(A1:E2;A1:E2)>0)*1)

Cette formule matricielle accepte les cellules vides et du texte, à valider par Ctrl+Maj+Entrée
=NB.SI(A1:E2;"<>""")-{SOMMEPROD(SI(A1:E2<>"";1/NB.SI(A1:E2;A1:E2)))

abcd
 

BOISGONTIER

XLDnaute Barbatruc
Repose en paix
Re : chiffres communs sur 2 plages

Bonjour,

Voir PJ


JB
 

Pièces jointes

  • Classeur1.xls
    13.5 KB · Affichages: 59
  • Classeur1.xls
    13.5 KB · Affichages: 62
  • Classeur1.xls
    13.5 KB · Affichages: 64
  • FonctionCommunsx.xls
    34 KB · Affichages: 70
  • FonctionCommunsx.xls
    34 KB · Affichages: 73
  • FonctionCommunsx.xls
    34 KB · Affichages: 70
Dernière édition:
J

JJ1

Guest
Re : chiffres communs sur 2 plages

RE,
merci pour vos formules mais je pense inadaptées à mon cas (mauvaise explication)
mes plages sont en lignes, ex A1:E1 et A2:E2 et non en colonne.
je pensais à une formule du genre:
= nb.si(sommeprod(A1:E1;A2:E2) >0
Votre avis?
merci beaucoup
ps: ce sont des chiffres sans des cellules vides
 

Discussions similaires

Réponses
17
Affichages
592
Réponses
5
Affichages
223

Statistiques des forums

Discussions
312 883
Messages
2 093 233
Membres
105 657
dernier inscrit
dominique pinocchio