XL 2019 Chercher dans une cellule un mot provenant d'une liste (excluant doublon)

PaulineSan

XLDnaute Nouveau
Bonjour,
J'aurais besoin d'un coup de main pour la formule
=SI(SOMMEPROD((critT<>"")*ESTNUM(TROUVE(critT;B2)))=0;"-";INDEX(critT;SOMMEPROD((critT<>"")*ESTNUM(CHERCHE(critT;B2))*LIGNE(critT))-LIGNE('categ SAP'!$A$1)))

Je recherche à catégoriser une liste de référence produit en fonction des mots qu'ils contiennent. (crit)
la BdD produit contient des références telles que:
LAQUE FORTE 150 ML
SHAMP 100 ML DELUX AMBER
APRES - SHAMPOING 100 ML DELUX

J'ai associé des mots clef "crit" à mes catégories comme SHAMP -> Shampoing -> Soin des cheveux.
Cela fonctionne plutôt bien sauf quand il trouve plusieurs crit dans la référence. Alors la formule cumule le nombre des lignes et me renvoi a une donnée incohérente.
( ex: APRES - SHAMPOING 100 ML DELUX contient et Apres - Shampoing et SHAMP) Les critères sont comptés 2 fois et me renvois à une 3eme ligne.

Y a t il une autre façon de faire ma recherche?
Ou alors de lui faire trouver le premier crit seulement (vaut mieux presque bon que tout à faux faux)?

Voici un exemple en fichier

Un GRAND merci d'avance
P
 

Pièces jointes

  • Test cherche.xlsx
    14.9 KB · Affichages: 11

Statistiques des forums

Discussions
311 101
Messages
2 077 036
Membres
242 010
dernier inscrit
Ratovonamana