Catégorie automatique...

fabian123

XLDnaute Occasionnel
Bonjour à toutes et tous!

Voici ma question:

je souhaiterais que lorsque j'encode dans une cellule un article, il s'affiche dans la cellule adjacente la catégorie de cet article:

par exemple j'ai les articles suivants:

barre chocolat blanc, barre caramel, barre nougat ,barre chocolat noir, ils se trouvent tous dans la catégorie "barre chocolatée"
chips sel, chips paprika, chips bolognèse se trouvent dans la catégorie "snack salé"

j'ai pensé utiliser une formule "SI":

=SI(B1="barre";A1="Barre chocolatée";si(B1="chips";A1="Snack salé";" "))

mais en mettant cette formule, il me laisse la cellule A1 vide, pour que cela fonctionne je dois mette "Barre chocolat blanc", puis "barre caramel"... cela me fait donc une formule à ralonge!!

est-il possible de n'utiliser que le mot "barre" comme référence?

j'espere que je me suis fait plus ou moins comprendre...

merci d'avance pour votre aide!
 

jmd2

XLDnaute Accro
Re : Catégorie automatique...

hello

le mieux est de prévoir une table de données
en A les articles
en B les catégories

et tu utilises la fonction RECHERCHEV (voir sur ce forum les messages existants pour cette fonction)
 

abcd

XLDnaute Barbatruc
Re : Catégorie automatique...

Bonjour,

Question déjà posée ici :
https://www.excel-downloads.com/search/
et laissée sans réponse.
Le mieux est de ne pas créer un nouveau message pour une question identique.

Comme le dit jmd2, il faut établir un tableau de correspondances.
Le mieux serait que tu mettes un exemple de ce que tu as et de ce que tu souhaites obtenir en pièce jointe.
Ce sera plus facile pour essayer de t'aider.

abcd
 

Statistiques des forums

Discussions
311 999
Messages
2 084 467
Membres
102 581
dernier inscrit
Michou