Microsoft 365 Calculer l'ecart entre la valeur courante et la valeur max dans une plage

arrot

XLDnaute Nouveau
Supporter XLD
bonjour
je voudrais pour chaque valeur du champ ticker analyser la derniere valeur fournie de close et calculer l’ecart avec la valeur max de ce champ ticker dans la colonne high sur les 10 dernières valeurs de dates
nota : dans le fichier joint je n’ai produit que 2 valeurs de ticker. En réalité mon fichier en contient une centaine
merci de votre aide
cordialement
André
 

Pièces jointes

  • uc vl sur 1 an.xlsx
    10.8 KB · Affichages: 4

JHA

XLDnaute Barbatruc
Bonjour à tous,

Avec ce que je comprends
VB:
=SI(LIGNE()=GRANDE.VALEUR(SI($A$2:$A$28=$A2;LIGNE($A$2:$A$28));1);MAX(DECALER(INDIRECT("$E"&GRANDE.VALEUR(SI($A$2:$A$28=$A2;LIGNE($A$2:$A$28));1));;;-10))-$E2;"")

JHA
 

Pièces jointes

  • uc vl sur 1 an.xlsx
    12.2 KB · Affichages: 1

job75

XLDnaute Barbatruc
Bonjour arrot, JHA,

Les dates en colonne C étant classées il suffit de considérer les 10 dernières valeurs de la colonne E.

Formule en G2 :
Code:
=E2-MAX(DECALER(E$1;EQUIV(9^9;E:E)-1;;-10))
A+
 

Pièces jointes

  • uc vl sur 1 an.xlsx
    11.7 KB · Affichages: 1

Discussions similaires

Statistiques des forums

Discussions
313 209
Messages
2 096 239
Membres
106 541
dernier inscrit
edf