calculer l'âge ???

p'tite véro

XLDnaute Nouveau
Bonsoir à tous,
Excel/access peut-il calculer l'âge d'une personne à aujourd'hui lorsqu'on à sa date de naissance au format (00/00/00).
Si l'un des génies actuellement connectés peut me communiquer la formule, je le remercie vivement par avance.
Bonne soirée à tous.
 

Brigitte

XLDnaute Barbatruc
Re : calculer l'âge ???

Bonjour,

Une formule pour calculer l'âge en années/mois/jours :

=SI(DATEDIF(A3;B3;"y")=0;;DATEDIF(A3;B3;"y")&SI(DATEDIF(A3;B3;"y")>1;" ans ";" an "))&DATEDIF(A3;B3;"ym")&" mois "&DATEDIF(A3;B3;"md")&SI(DATEDIF(A3;B3;"md")>1;" jours "; " jour ")

en A3 : date naissance ou autre
en B3 : date du jour : on peut à la place mettre aujourdhui() ou maintenant().

Une autre : =ENT((MAINTENANT()-A10)/365,25)&" ans" (en A10 la date de naissance)

Bon courage

PS : le rouge sur le datedif, c pour contourner le pb d'espace que met xld dans les formules, sinon elle va pas marcher...
 
Dernière édition:

Brigitte

XLDnaute Barbatruc
Re : calculer l'âge ???

Bonjour,

Purée, je pigeai pas l'intervention de Gilbert :
euhhh, c'est moi ça :D

Je crois que j'ai compris, c'est ta date de naissance ?

Et pi, pourquoi faire simple, quand on peut faire compliqué... Moi les calculs d'âge, j'ai tjs rien compris.. ou jamais, c'est selon.

Euh JC, tu veux dire quoi ?
Euh, la Team, on ne peut pas prendre un plus vieux que moi... Pour me remettre à "niveau" A+ à tous :mad:

J'ai pas les idées claires moi.

Bisous au passage, cher BarbaJC
 

chris

XLDnaute Barbatruc
Re : calculer l'âge ???

Bonjour

Le problème c'est qu'avec la formule
=ANNEE(A1)-ANNEE(B1)
on a un an de plus dès le 1er janvier même si on est né en décembre.

donc DATEDIF est plus approprié.

skoobi est pressé de vieillir pour rejoindre la team JCGL :p?
 

skoobi

XLDnaute Barbatruc
Re : calculer l'âge ???

Bonjour

Le problème c'est qu'avec la formule
=ANNEE(A1)-ANNEE(B1)
on a un an de plus dès le 1er janvier même si on est né en décembre.

donc DATEDIF est plus approprié.

skoobi est pressé de vieillir pour rejoindre la team JCGL :p?

Salut Chris :),

un peu brut de décoffrage ma formule c'est vrai.
On me dis souvent que je ne fais pas mon âge donc :cool:, mais au fait JC, faudrait actualiser la photo non? :D (et une de plus :p).

Bonne journée à vous :).
 

Discussions similaires

Réponses
16
Affichages
651

Membres actuellement en ligne

Aucun membre en ligne actuellement.

Statistiques des forums

Discussions
312 084
Messages
2 085 194
Membres
102 813
dernier inscrit
kaiyi