calculer des commissions ??

S

sendero

Guest
Bonjour vous tous,

j'ai une petite question,
Depuis quelques temps, je desir faire une formule de calcul pour des commissions voici les explications

Si la valeur d'une certaine cellule est :

plus petite que 1300$ * 15%
entre 1301$ et 1800$ * 17%
plus grande que 1800$ * 20%

En resumé, la feuille de calcul actuel additionne et soustrais les montants en $ de plusieurs cellules. Le résultat de ces calculs va toujours être entre 0$ et plus de 2000$, ce résultat doit être ensuite multiplié selon les % si haut et le résultat de ce calcul donnera la comission du personnel...

Merci BEAUCOUP, cette formule sera surement très facile pour plusieurs d'entre vois mais moi je n'y arrive pas seul

Encore merci,

Marc-André
Amos, Québec
 

bencourriel

XLDnaute Occasionnel
Bonsoir sendero, le forum,

Si je comprends bien, voici :

Supposons que ta valeur est dans la cellule A1,

=SI(A1<1300;0,15*A1;SI(A1<1800,01;0,17*A1;SI(A1>1800;0,20*A1;0)))

La logique est la suivante :
Toute valeur inférieur de 1300,00 sera une commission à 15%,
ensuite, si ça ne répond pas au premier critère, toute valeur inférieure à 1800,01 sera une commission à 17%
et finalement, si aucune de ces conditions n'est remplis, toute valeur supérieure à 1800 sera à 20% de commission.

Bonne soirée!

Message édité par: bencourriel, à: 27/10/2005 03:42
 

andré

XLDnaute Barbatruc
Salut sendero et bencourriel,

Autre solution, un peu plus courte (18 caractères) :

=(A1*15%)+(A1>=1300)*(A1*2%)+(A1>1800)*(A1*3%)

La formule de bencourriel peut aussi être raccourcie :

=SI(A1<1300;0,15*A1;SI(A1<1800,01;0,17*A1;0,20*A1;0))
mais quand même encore 4 caractères de plus (lol).

Â+
 

dg62

XLDnaute Barbatruc
Bonjour le fil


si j'ai bien compris le problème, il s'agit d'un calcul par tranche.

La cellule de référence est nommée TotCA.


=si(totca<1301; totca*0,15;si(totca<1800;195+(TotCA-1300)*0,17;195+85+(TotCA-1800)*0,2))


195 = 1300*0,15
85=500*0,17 (1800-1300)
280=195+85

=si(totca<1301; totca*0,15;si(totca<1800;195+(TotCA-1300)*0,17;280+(TotCA-1800)*0,2))
 

andré

XLDnaute Barbatruc
Salut dg62,

Nous n'avons pas compris la même chose.

Pour toi un montant de 1600 donne 15 % sur 1300 + 17 % sur 300.

Pour moi un montant de 1600 donne 17 % sur 1600

De plus le terme 'entre' prête à confusion.
On ne sait pas ce qu'il faut faire avec 1300, 1301 et 1800.

Attendons sendero !

Â+