Calcul nombre d'occurrences avec condition

patman

XLDnaute Nouveau
Bonjour à tous et à toutes.

Je recherche une formule me permettant de faire le calcul indiqué dans le titre.

J'ai cherché, mais pas trouvé.

La formule devrait me donner le nombre de fois où je peux trouver le chiffre 6 dans la colonne G si il y a un A dans le colonne A

Merci aux spécialistes
 

Pièces jointes

  • Classeur1.xls
    13.5 KB · Affichages: 76
  • Classeur1.xls
    13.5 KB · Affichages: 75
  • Classeur1.xls
    13.5 KB · Affichages: 73

Spitnolan08

XLDnaute Barbatruc
Re : Calcul nombre d'occurrences avec condition

Bonjour le fil,

Pourquoi faire simple quand on peut faire compliqué ?
Je te propose donc un peu plus compliqué que la très bonne proposition d'abcd pour des données en A1:G11 :

=SOMME((A1:A11="A")*(G1:G11=6))

sous forme de formule matricielle à valider par Ctrl + Maj + Entrée

Cordialement
 

MJ13

XLDnaute Barbatruc
Re : Calcul nombre d'occurrences avec condition

Bonjour à tous,

Voici une solution avec BDNB (c'est une autre possibilté pour la gestion de BDD).
 

Pièces jointes

  • BDCritères_MJ.xls
    19.5 KB · Affichages: 72

patman

XLDnaute Nouveau
Re : Calcul nombre d'occurrences avec condition

Merci pour vos réponses rapides, mais...

çà ne marche pas !!!

En effet, je souhaite que dans la formule, la valeur ici appelée A soit non pas citée, mais appelée.

J'ai essayé de changer
=SOMME((A1:A11="A")*(G1:G11=6))
en
=SOMME((A1:A11=A1)*(G1:G11=6))

Mais çà ne marche pas non plus. Je précise que j'ai excel 2003.

Avec la gestion de BDD, je n'ai pas essayé car je préfère ne pas avoir à créer de cases avec les critères.

Je peux éventuellement joindre le fichier, mais actuellement, il est un peu gros pour être joint ici
 

Tibo

XLDnaute Barbatruc
Re : Calcul nombre d'occurrences avec condition

Bonsoir patman,

as-tu essayé la formule proposée par abcd ?

Sinon, je ne comprends pas ce que tu veux dire : "je souhaite que dans la formule, la valeur ici appelée A soit non pas citée, mais appelée" ???

En ce qui concerne la formule proposée par l'ami Spitnolan, l'as-tu bien validée par CTRL + MAJ + ENTREE

Enfin, il faut éviter de dire "ça ne marche pas" sans autre précisions.

Le mieux est de nous donner le résultat attendu et là, on sait alors où il faut arriver (en principe...)

A te (re)lire avec plus de précisions.

@+
 

Spitnolan08

XLDnaute Barbatruc
Re : Calcul nombre d'occurrences avec condition

Re,
Bonsoir Tibo:),

Je pense qu'il veut dire que la valeur à prendre en compte peut être différente de "A" et doit correspondre à celle qui est saisie en cellule A1.

Mais ce n'est qu'une interprétation et comme patman n'est pas très clair dans sa réponse, je ne me suis pas penché sur le pb (Si tant est que je sache répondre à mon interprétation...)

Bonne soirée
 

patman

XLDnaute Nouveau
Re : Calcul nombre d'occurrences avec condition

Bonjour, et désolé pour la pauvreté de ma réponse d'hier.

Comme suggéré,
(...)
Je pense qu'il veut dire que la valeur à prendre en compte peut être différente de "A" et doit correspondre à celle qui est saisie en cellule A1. (...)

C'est bien ce que je veux faire.

Je vous joins un lien vers mon fichier.
FICHIER (sur sendspace)

Comme vous le voyez, c'est un fichier de statistiques sur le basket

Ce que je veux faire:
Feuille "Officiels" (la feuille "Amicaux" est identique)
Colonne AG
Cellule AG3 et suivantes (AG4, AG5...)
J'aimerai trouver le nombre de fois où le joueur cité en AGx a été exclu dans un match.
Sachant qu'il est exclu si dans le tableau C82:S100 le chiffre "6" apparait en face de son nom (C82:C1000) dans la colonne Q (Q82:Q1000)

EN espérant avoir été assez clair !

Merci, et encore désolé
 

abcd

XLDnaute Barbatruc
Re : Calcul nombre d'occurrences avec condition

Bonjour,

La formule proposée comme 1ère réponse est bonne, il suffit d'adapter les références des plages :
AG3 : =SOMMEPROD(($C$82:$C$1000=$C3)*($Q$82:$Q$1000=6))
cette formule est à copier vers le bas.

abcd
 

patman

XLDnaute Nouveau
Re : Calcul nombre d'occurrences avec condition

Bonjour,

La formule proposée comme 1ère réponse est bonne, il suffit d'adapter les références des plages :
AG3 : =SOMMEPROD(($C$82:$C$1000=$C3)*($Q$82:$Q$1000=6))
cette formule est à copier vers le bas.

abcd


Effectivement, çà marche. J'avais du merdé quelque part lors de la première recopie.

Merci beaucoup à tous pour le coup de main et la rapidité
 

Discussions similaires

Statistiques des forums

Discussions
312 084
Messages
2 085 194
Membres
102 813
dernier inscrit
kaiyi