XL 2016 Calcul du nombre de minutes dans un créneau horaire

loulourav

XLDnaute Occasionnel
Bonjour à tous,

Je sollicite vos compétences car je ne trouve pas la solution à mon problème !
j'ai un tableau avec des Heures d'entrées et des heures de sorties, je cherche à calculer le temps passé en minutes par tranche de 15 min.
exemple entré à 22:23 et sortie à 23:51 je veux voir sur le créneau 22:15 : 0 / 22:30 : 7 / 22:45 : 15 / 23:00 : 15 etc ...
Actuellement ma formule fonctionne mais additionne les temps depuis l'heure d'entrée j'ai donc : 22:15 : 0 / 22:30 : 22 / 22:45 : 37 / 23:00 : 52 etc ...

Comment bien calculer les temps par créneau de 15 min et non pas cumulé ?
un fichier exemple en pj ;)

Merci !
 

Pièces jointes

  • ficer exemple minute.xlsx
    14.2 KB · Affichages: 8

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonjour Loulourav,
Ha, la gestion des heures sous XL ... on pourrait écrire un livre. :)
Un essai sous XL à bien vérifier , avec en E2 :
VB:
=SI((-$A2+F$1)*($B2-E$1)<0;"";MIN(MIN((-$A2+F$1);($B2-E$1));"00:15"*1))
J'ai mis en colonne C le temps passé, et en colonne D la somme des temps calculés. Normalement les deux valeurs sont égales.
 

Pièces jointes

  • ficer exemple minute.xlsx
    15.7 KB · Affichages: 4

loulourav

XLDnaute Occasionnel
Bonjour Loulourav,
Ha, la gestion des heures sous XL ... on pourrait écrire un livre. :)
Un essai sous XL à bien vérifier , avec en E2 :
VB:
=SI((-$A2+F$1)*($B2-E$1)<0;"";MIN(MIN((-$A2+F$1);($B2-E$1));"00:15"*1))
J'ai mis en colonne C le temps passé, et en colonne D la somme des temps calculés. Normalement les deux valeurs sont égales.
Bonjour sylvanu et merci bcp pour ta réponse !
effectivement ca fonctionne bien pour les données exemple que je t'ai transmises, mais (et oui il y a un mais ...) j'ai aussi des données qui commence en J et se termine en J+1 ... dans ce cas de figure la formule est erreur puisque l'heure de sortie est inférieure à l'heure d'entrée ... j'ai modifier le fichier exemple en pj en ajoutant les champs date/heure ...désolé pour cet oubli regrettable ...
 

Pièces jointes

  • fichier exemple minute.xlsx
    28.3 KB · Affichages: 3

sylvanu

XLDnaute Barbatruc
Supporter XLD
j'ai modifier le fichier exemple en pj en ajoutant les champs date/heure
Une solution simple est de rajouter une colonne.
Si l'heure de sortie est avant l'heure d'entrée on rajoute un jour.
( en supposant que sortie et entrée se font en moins de 2 jours ,)
VB:
=SI(B2<A2;B2+1;B2)
Si l'ajout d'une colonne n'est pas possible, il suffit de remplacer B2 par cette formule dans toutes les cellules, mais ça va alourdir le fichier et ralentir les calculs.
 

Pièces jointes

  • fichier exemple minute V2.xlsx
    24.4 KB · Affichages: 2

loulourav

XLDnaute Occasionnel
Une solution simple est de rajouter une colonne.
Si l'heure de sortie est avant l'heure d'entrée on rajoute un jour.
( en supposant que sortie et entrée se font en moins de 2 jours ,)
VB:
=SI(B2<A2;B2+1;B2)
Si l'ajout d'une colonne n'est pas possible, il suffit de remplacer B2 par cette formule dans toutes les cellules, mais ça va alourdir le fichier et ralentir les calculs.
@sylvanu : vérif faites ca ne fonctionne pas dans tout les cas de figure, cf ligne 13 de ton fichier ;)

de mon côté j'ai 140 lignes en écart sur 6900, c'est pas énorme mais je vois pas comment corriger oO
 

sylvanu

XLDnaute Barbatruc
Supporter XLD
Re,
Exact. Mais je pense que le souci vient du fait que votre planning couvre 24H, de 00:00 à 00:00.
Or en ligne 13 on va sur 2 jours.
Par ex si vous entrez à 23:00 et sortez à 01:00, cela vous donnera un temps de 60min.
Les dernières 60min sont sur le lendemain.
Sur la ligne 13 vous avez 12+15 min sur ce jour, le reste le lendemain.
 

sylvanu

XLDnaute Barbatruc
Supporter XLD
Par ex, en PJ j'ai continué le planning, et cela semble marcher.
Par contre, tout dépend de ce que vous voulez en faire. Car le planning court sur 2 jours donc des calcul par jour deviendraient erronés, sauf à les reprendre.
 

Pièces jointes

  • fichier exemple minute V3.xlsx
    33.1 KB · Affichages: 3

Discussions similaires

Statistiques des forums

Discussions
313 271
Messages
2 096 724
Membres
106 720
dernier inscrit
Alain EDZOA