Calcul d'occurences suivant le mois d'une date

Polo34

XLDnaute Junior
Bonsoir le FORUM
Voici mon pb:

A partir d'une liste de dates (liste nommée et extensible), je souhaite récupérer le nombre d'occurences mensuelles.
Je vous transmets un petit fichier qui vous montrera les choses plus clairement.
Merci à vous pour m'aider concernant ma difficulté qui sera certainement simple à résoudre pour vous

A bientot

Polo34
 

Pièces jointes

  • Occurences Polo34.xlsx
    11.1 KB · Affichages: 41

R@chid

XLDnaute Barbatruc
Re : Calcul d'occurences suivant le mois d'une date

Bonsoir,
en B3,
Code:
=SIERREUR(SOMMEPROD(N(MOIS(DECALER(date!$A$2;;LIGNES($3:3)-1;NBVAL(DECALER(date!$A:$A;;LIGNES($3:3)-1))-1))=B$2));"")
@ tirer vers le bas et vers la droite
@ micalement
 

mapomme

XLDnaute Barbatruc
Supporter XLD
Re : Calcul d'occurences suivant le mois d'une date

Bonsoir Polo34,

Une petite autre en B3 (juste pour saluer R@chid :) ):
Code:
=SOMMEPROD((DECALER(date!$A$2:$A$100;0;LIGNES(B$2:B3)-2)<>"") * (MOIS(DECALER(date!$A$2:$A$100;0; LIGNES(B$2:B3)-2)) =B$2))
A copier vers la droite puis vers le bas. Augmenter la valeur 100 si nécessaire...
 
Dernière édition:

Polo34

XLDnaute Junior
Re : Calcul d'occurences suivant le mois d'une date

Salut le Forum

Salut R@chid et Mapomme

Merci pour les solutions apportées. Les 2 fonctionnent parfaitement
Il fallait les trouver ces formules !!!

Merci encore et bonne journée

Polo34
 

Discussions similaires

Statistiques des forums

Discussions
312 947
Messages
2 093 843
Membres
105 852
dernier inscrit
Bast