Calcul de la periodicite des pics et creux automatiquement

serir

XLDnaute Junior
Bonjour :cool:,


Ma question se trouve dans le fichier


Merci beaucoup
 

Pièces jointes

  • Périodicité pics et creux.xlsx
    22.9 KB · Affichages: 45
  • Périodicité pics et creux.xlsx
    22.9 KB · Affichages: 46
  • Périodicité pics et creux.xlsx
    22.9 KB · Affichages: 47

Dranreb

XLDnaute Barbatruc
Re : Calcul de la periodicite des pics et creux automatiquement

Bonjour.
De toute évidence il y a une périodicité de 7 jours dans le phénomène.
Il devrait être possible de calculer l'allure d'une courbe périodique sur une semaine dont la somme de carrés des écarts avec les valeurs notées est la plus petite possible.
Cela répondrait-il à ce que vous cherchez ?
À +
 

serir

XLDnaute Junior
Re : Calcul de la periodicite des pics et creux automatiquement

Bonjou,
Désolé, j'ai pas compris.

Je voulais afficher "automatiquement" tous les pics et creux sur un tableau avec les jours qui correspondent et la periode la plus frequente pour que ces pics et creux se produise.

Merci pour votre comprehension
A +
 

Modeste geedee

XLDnaute Barbatruc
Re : Calcul de la periodicite des pics et creux automatiquement

Bonsour®
:confused:
31/04/2012
31/06/2012

en tant qu'approche de calcul, déterminer d'abord la référence à prendre en compte :
- Ecart par rapport à la valeur précédente (absolu ou en %)
- ecart par rapport à la moyenne
- ecart par rapport à la tendance

ensuite afficher les dates pour lesquelles l'écart est supérieur à une valeur à choisir

un exemple :
l'analyse et la correlation avec des événements exterieurs est une autre affaire (metéo, jours fériés, biens de consommation : habillement ou nourriture, saisonnalité...)
en première lecture : émergence du mercredi : jour des enfants ???
 

Pièces jointes

  • Périodicité pics et creux .xlsx
    31.5 KB · Affichages: 45

Dranreb

XLDnaute Barbatruc
Re : Calcul de la periodicite des pics et creux automatiquement

Je ne sais pas faire ça, désolé.
L'analyse harmonique sur 7 jour ne donne rien de bien exploitable non plus, et l'approche polynomiale n'est certainement pas adéquate.
Peut être une simple moyenne des valeurs prises tous les 7 jours, je ne sais pas.
 

CISCO

XLDnaute Barbatruc
Re : Calcul de la periodicite des pics et creux automatiquement

Bonjour

Une voie possible en pièce jointe.

On peut aussi, plus rigoureusement, travailler avec le changement de signe de la dérivée.

@ plus
 

Pièces jointes

  • Périodicité pics et creux.xlsx
    24.9 KB · Affichages: 52
  • Périodicité pics et creux.xlsx
    24.9 KB · Affichages: 49
  • Périodicité pics et creux.xlsx
    24.9 KB · Affichages: 46

Dranreb

XLDnaute Barbatruc
Re : Calcul de la periodicite des pics et creux automatiquement

Voyez ce que pourrait vous apporter cette formule en D3:
Code:
=SOMME((MOD($B$3:$B$118;7)=MOD($B3;7))*$C$3:$C$118)/SOMME(N(MOD($B$3:$B$118;7)=MOD($B3;7)))
validée par Ctrl+Maj+Entrée, propagée vers le bas, puis ajoutée comme nouvelle série dans le graph.
Cordialement.
 

Statistiques des forums

Discussions
312 931
Messages
2 093 719
Membres
105 794
dernier inscrit
mallet