Autres Calcul avec FREQUENCE dans 2 feuilles ...

BGUEGAN

XLDnaute Nouveau
Bonjour,

Je ne suis pas un grand spécialiste d'excel. Mais je me débrouille un peu. J'ai un souci à régler, voilà j'ai deux feuilles de calcul :
  1. 'Adhérents' avec les colonnes (NUM ANNÉE NOM PRÉNOM DATE DE NAISSANCE NOYAU DUR) ;
  2. 'Cotisations & Dépenses' avec les colonnes (NUM ANNÉE NOM PRÉNOM NUMÉRO ADHÉRENT CRÉDIT – DÉBIT).

Je cherche à calculer (sans doublons) le nombre d'adhérents de la feuille 'Cotisations & Dépenses' pour une année donnée en paramètre (année de la feuille 'Cotisations & Dépenses'), faisant partie du NOYAU DUR ? Soit la valeur de cette colonne à 'Oui', sachant que cette colonne est dans la feuille 'Adhérents'. Le NUMÉRO ADHÉRENT correspond au NUM de la feuille 'Adhérents' (comme une clé secondaire d'une table de BDD).

En document joint le fichier ... Ici je devrais avoir pour 2013 la valeur 3 et pour 2014 la valeur est 1 et pour 2015 la valeur 0.

En vous remerciant par avance, car j'ai essayé avec FREQUENCE et tout et tout sans résultat, car je n'arrive pas à aller chercher l'information sur le NOYAU DUR dans l'autre feuille ...

Merci pour votre aide !

Bien cordialement,
Bruno GUEGAN
 

Pièces jointes

  • test.xls
    12 KB · Affichages: 4
  • test.xlsx
    8.8 KB · Affichages: 4
Dernière édition:
Solution
Bonjour Voilà j'ai trouvé la solution ... Une formule matricielle : {=NB.SI(NB.SI.ENS($'Cotisations & Dépenses'.$B$2:$B$330;A3;$'Cotisations & Dépenses'.$E$2:$E$330;SI($Adhérents.$F$2:$F$270="Oui";$Adhérents.$A$2:$A$270));"<>0")}

Dans l'onglet : Pré - statistiques

Bien cordialement,

BGUEGAN

XLDnaute Nouveau
Re
avec une colonne cachée et un tcd
en 2014==>0
Merci pour ce travail, mais en fait, je ne peux pas ajouter de nouvelles colonnes nul part, et je ne peux pas non plus utiliser les segments, car sous libreoffice je ne pourrais pas les utiliser, ça n'existe pas pour l'instant dans calc. En fait, je recherche une formule miracle sans devoir modifier quoi que ce soit d'autre et qui fonctionnerait autant sous excel que sous calc.

Un truc dans ce genre là, B33 contiendrait l'année :
=SOMME(SI(FREQUENCE(SI(($'Cotisations & Dépenses'.$B$2:$'Cotisations & Dépenses'.$B$27=B33)*($Adhérents.$E$2:$Adhérents.$E$27=$'Cotisations & Dépenses'.$A$2:$'Cotisations & Dépenses'.$A$27)*($'Cotisations & Dépenses'.$I$2:$'Cotisations & Dépenses'.$I$27="Oui");($'Cotisations & Dépenses'.$B$2:$'Cotisations & Dépenses'.$B$27=B33)*($Adhérents.$E$2:$Adhérents.$E$27=$'Cotisations & Dépenses'.$A$2:$'Cotisations & Dépenses'.$A$27)*($'Cotisations & Dépenses'.$I$2:$'Cotisations & Dépenses'.$I$27="Oui")>0;1))

Mais ça ne fonctionne pas ...

Merci beaucoup d'y avoir réfléchi. C'est très gentil.

Bien cordialement
 

BGUEGAN

XLDnaute Nouveau
Bonjour Voilà j'ai trouvé la solution ... Une formule matricielle : {=NB.SI(NB.SI.ENS($'Cotisations & Dépenses'.$B$2:$B$330;A3;$'Cotisations & Dépenses'.$E$2:$E$330;SI($Adhérents.$F$2:$F$270="Oui";$Adhérents.$A$2:$A$270));"<>0")}

Dans l'onglet : Pré - statistiques

Bien cordialement,
 

Pièces jointes

  • recherche_dans-2-feuilles-critere-ds-une.xlsx
    10.9 KB · Affichages: 1

Discussions similaires

Statistiques des forums

Discussions
312 819
Messages
2 092 377
Membres
105 383
dernier inscrit
Hyorish