XL 2019 Automatiser des formules

cotignac

XLDnaute Nouveau
Bonjour,

Je cherche à automatiser des formules dans mes fichiers.
Dans le fichier ci-joint j'aimerai obtenir (par exemple avec une sélection de C28 à C42) :
- le nombre de cellules sélectionnées en cellule J42
- la somme des nombres contenus dans les cellules C28 à C42 en cellule K42
- la somme des nombres contenus dans les cellules D28 à D42 en cellule L42
- et la moyenne des nombres contenus dans les cellules E28 à E42 en cellule M42

Est-ce que c'est possible en sélectionnant juste une plage ou est-ce que je dois rentrer ma plage dans une cellule ?
Je vais devoir sélectionner de nombreuses plages donc je cherche à aller au plus vite.

En vous remerciant par avance pour vos réponses,
 

Pièces jointes

  • Test calcul auto.xls
    29 KB · Affichages: 1
Solution
Bonjour à tous,

En cellule "H42" il y a le début de la plage
En cellule "I42" il y a la fin de la plage

Ensuite, il y a deux formules, une avec les lettres des plages en ligne 41 (H41:M41), cela te permet de ne pas changer la formule quand tu copies sur la droite,
VB:
=SOMME(INDIRECT(K$41&$H$42&":"&K$41&$I$42))
puis tu remplaces somme par moyenne en "M42" .
Code:
=MOYENNE(INDIRECT(M$41&$H$42&":"&M$41&$I$42))

puis une seconde avec les lettres en "dur" dans la formule moins pratique car il faut se taper toute les formules une par une.

JHA

cotignac

XLDnaute Nouveau
@JHA je ne comprends pas comment ça marche et je ne trouve pas les bons résultats.
Par contre, ce que je pense avoir compris c'est que je dois rentrer la plage "debut-fin" ?
J'ai 3 sommes et une moyenne, alors que normalement je dois avoir 2 sommes , une moyenne, et je ne sais pas quoi pour décompter le nombre de cellules concernées par les formules.
Dans ton fichier j'ai 10 et 15 en début et fin.
Désolé je suis perdu là.
 

JHA

XLDnaute Barbatruc
Bonjour à tous,

En cellule "H42" il y a le début de la plage
En cellule "I42" il y a la fin de la plage

Ensuite, il y a deux formules, une avec les lettres des plages en ligne 41 (H41:M41), cela te permet de ne pas changer la formule quand tu copies sur la droite,
VB:
=SOMME(INDIRECT(K$41&$H$42&":"&K$41&$I$42))
puis tu remplaces somme par moyenne en "M42" .
Code:
=MOYENNE(INDIRECT(M$41&$H$42&":"&M$41&$I$42))

puis une seconde avec les lettres en "dur" dans la formule moins pratique car il faut se taper toute les formules une par une.

JHA
 

Pièces jointes

  • Test calcul auto 2.xlsx
    11 KB · Affichages: 1

Discussions similaires

Statistiques des forums

Discussions
313 205
Messages
2 096 209
Membres
106 530
dernier inscrit
miomi98