Attribuer texte selon un nombre

lecrabe

XLDnaute Nouveau
Bonjour,

Je travaille dans un hôtel et je cherche à nommer sur excel les bâtiments en fonction des numéros de chambres

J'ai un numéro de chambre en B3 et j'aimerai renvoyer en B4 le bâtiment auquel elle se rapporte.

EX le R 1 correspond au chambre de
101 à 112, 201 à 212, 301 à 312, 401 à 412, 501 à 512, 602 à 612, 701, 702, 703 et 704

Il y a 3 bâtiments R 1, R 2, et R 3.

J’ai rentré la formule:
=SI(ET(B3>100;B3<113);"R 1";...........SI(ET(B3>700;B3<705);"R 1";" "))

Mais j'ai l'impression qu'au bout de 7 formules "SI(ET" excel ne prends plus en compte la formule que puis-je faire ? sachant qu'avec cela je ne même pas fini le R 1.

Merci
 

JCGL

XLDnaute Barbatruc
Re : Attribuer texte selon un nombre

Bonjour à tous,
Bienvenue Le Crabe :),

Tu aurais intérêt à établir une table :

La chambre x égale le batiment x

La fonction SI() est limitée à 8 dans la même formule

Au plaisir de te lire

A+

Edition : Salut mon ami PJ :)
 
Dernière édition:

pierrejean

XLDnaute Barbatruc
Re : Attribuer texte selon un nombre

bonjour lecrabe

et bienvenue sur XLD

Si tu n'as rien contre une fonction personnalisée et si tu peux donner un peu plus de precisions il est possible de concocter quelque chose
Les precisions supplementaires (Affectation des N° de chambre aux batiments ) de preference dans un fichier exemple

Edit: Salut mon ami JC :)
 

JHA

XLDnaute Barbatruc
Re : Attribuer texte selon un nombre

Bonjour Lecrabe, le forum,

Un essai avec cette formule:
=SI(OU(ET(A1>=101;A1<=112);ET(A1>=201;A1<=212);ET(A1>=301;A1<=312);ET(A1>=401;A1<=412);ET(A1>=501;A1<=512);ET(A1>=602;A1<=612);ET(A1>=701;A1<=704));"R1";"Autre Batiment")

JHA
 

lecrabe

XLDnaute Nouveau
Re : Attribuer texte selon un nombre

Bonjour, je suis tres content d'etre sur ce forum

Merci à tous pour vos réponses trés rapides :)
j'ai suivi les conseils de JCGL et deBOISGONTIER, en créant une table avec un e recherchev ça marche trés bien.

Philippe
 

abcd

XLDnaute Barbatruc
Re : Attribuer texte selon un nombre

Bonjour,

Avec une liste complète des chambres, et le bâtiment auxquelles elles appartiennent, ce serait plus facile.

Je pense à une formule du type :
=SI(ET(MOD(B3;100)<13;B3<705);"R1";"un autre bâtiment")
Si les chambres au-delà de 704 n'existent pas, la formule peut être raccourcie.

abcd
 

Discussions similaires

C
Réponses
15
Affichages
2 K
C

Statistiques des forums

Discussions
312 923
Messages
2 093 663
Membres
105 780
dernier inscrit
Autric