arrondir si valeur de le 3ème décimale >= 6

melba

XLDnaute Occasionnel
Bonjour,

Puis-je avoir votre aide pour résoudre le problème cité en objet.

Dans un fichier j'ai en colonne B des nombres qui sont des résultats de calculs ( multiplications et divisions).

je souhaiterais que ces nombres soient arrondis suivant la valeur de la 3ème décimale : si celle-ci est supérieure strictement à 6 , la deuxième décimale doit augmenter.

Je joins un fichier qui sera assez clair je l'espère.

Merci pour votre attention.

@
 

JHA

XLDnaute Barbatruc
Re : arrondir si valeur de le 3ème décimale >= 6

Bonjour à tous,

A essayer avec le chiffre en "A1"

Code:
=SI(STXT(A1;CHERCHE(",";A1;1)+3;1)*1>6;ARRONDI.SUP(A1;2);A1)

Code:
=SI(STXT(A1;CHERCHE(",";A1;1)+3;1)*1>6;TEXTE(ARRONDI.SUP(A1;2);"00,000");TEXTE(A1;"00,000"))

Edit: Bonjour Roger

JHA
 
Dernière édition:

ROGER2327

XLDnaute Barbatruc
Re : arrondir si valeur de le 3ème décimale >= 6

Bonjour melba, JHA


Essayez ceci :​
Code:
=ARRONDI($A1-0,001;2)


ROGER2327
#6287


Samedi 14 Sable 140 (Don Quichotte, champion du monde - fête Suprême Quarte)
24 Frimaire An CCXXI, 6,0967h - oseille
2012-W50-5T14:37:55Z
 

melba

XLDnaute Occasionnel
Re : arrondir si valeur de le 3ème décimale >= 6

Bonsoir,

désolée de n'avoir pas pu vous remercier plus tôt pour vos réponses : cadeaux de noël obligent.

J'ai commencé à tester la proposition de JHA : =SI(STXT(A1;CHERCHE(",";A1;1)+3;1)*1>6;ARRONDI.SUP(A1;2);A1) qui fonctionne très bien. Cependant dans mes cellules je dois avoir des nombres avec 2 décimales. Si je formate avec "nombre et 2 décimales" excel me fait un arrondi qui ôte tout l'intérêt de la formule . Ce problème de format ne concernant que certains nombres, j'ai modifié la formule comme suit :
=SI(STXT(A1;CHERCHE(",";A1;1)+3;1)*1>6;ARRONDI.SUP(A1;2);tronque(A1;2)).

J'essaierai les autres propositions dès que possible et vous tiens au couranti.

Encore un grand merci.

@+
 

Discussions similaires

Membres actuellement en ligne

Aucun membre en ligne actuellement.

Statistiques des forums

Discussions
312 872
Messages
2 093 103
Membres
105 627
dernier inscrit
jean-marc.brillant