Aide Comment je peut compter une valeur monétaire

mohssin85

XLDnaute Nouveau
pour plus de detail j'ai besoin d'un formule qui compter le nombre de fois qu'un pièce monétaire presente dans une valeur chiffré
par exemple la valeur 120.5 euro

contient une piece de 100 euro et 2 piece de 10 euro et 1 piece de 0.5 cent

resultat est 100 = 1 piece
10 = 2 pieces
0.5 = 1 piece

comme ça je souhaite d'obtenir le resultat

finalement j'attend vos réponse
 

Staple1600

XLDnaute Barbatruc
Re : Aide Comment je peut compter une valeur monétaire

Bonsoir


Est-ce que tu veux une formule pour compter combien de fois ton message contient la pièce "bonjour" et la formule matricielle (validation par touche MAJ+MERCI) pour la pièce "Merci', comme le signale Brigitte (bonsoir à toi)
 
Dernière édition:

abcd

XLDnaute Barbatruc
Re : Aide Comment je peut compter une valeur monétaire

Bonsoir,

J'ai vu un progarmme à télécharger (free) sur VeriTi qui répond à la demande, mais je ne me souviens plus de son nom.

Si tu ne trouves pas, je dois en avoir une copie quelque part.

abcd
 

Tibo

XLDnaute Barbatruc
Re : Aide Comment je peut compter une valeur monétaire

Bonsoir,

Pour mohssin85, un premier lien (le plus important) :

Lien supprimé

Il s'agit de quelques règles de bases pour bien coexister dans la maison XLD.


Ensuite, après une demande de t'ite Couettes en MP, j'ai regardé ton problème.

Ayant commis quelque chose, je te le livre.

Basé sur la fonction SOMMEPROD.

Les montants à décomposer en colonne A

les billets et pièces de C1 à O1

En C2, cette formule :

Code:
=SI($A2-SOMMEPROD(($B$1:B$1)*($B2:B2))>=C$1;ENT(($A2-SOMMEPROD(($B$1:B$1)*
($B2:B2)))/C$1);0)

à recopier vers la droite et vers le bas.

nécessite de laisser la colonne B vide (colonne qui peut être masquée).

Par simplification, je livre le fichier.

Il existe très certainement d'autres solutions. Peut-être même une recherche dans le Forum pourrait permettre d'en trouver d'autres.

@+
 

Pièces jointes

  • Décomposition montant.zip
    2 KB · Affichages: 24

Brigitte

XLDnaute Barbatruc
Re : Aide Comment je peut compter une valeur monétaire

Bonsoir,

J'en étais sûre. Monsieur FORMULEARALLONGES (on dirait DULL hi hi) avait plus d'un tour dans son sac.

Bravo et merci Tibo, moi je vais regarder ca.

Bisous à tous.
 

abcd

XLDnaute Barbatruc
Re : Aide Comment je peut compter une valeur monétaire

Bonsoir, salut Tibo,

Pourquoi avoir fait l'impasse sur la valeur monétaire 0.02 ?
Il y a de petits problèmes avec les centimes, voir pièce jointe.

Une proposition en variante, aussi sous la pièce jointe.

abcd
 

Pièces jointes

  • DécompositionMontant.xls
    21.5 KB · Affichages: 82

Tibo

XLDnaute Barbatruc
Re : Aide Comment je peut compter une valeur monétaire

Bonjour,

Effectivement, j'avais zappé les pièces de 2 centimes...

Sinon, pour les erreurs constatées, cela tient à Excel (ou peut-être au processeur), du fait de soucis sur les calculs avec les nombres à virgule.

En insérant la fonction ARRONDI dans la formule, tout rentre dans l'ordre.

En C1, la formule devient :

Code:
=SI(ARRONDI($A2-SOMMEPROD(($B$1:B$1)*($B2:B2));2)>=C$1;
ENT((ARRONDI($A2-SOMMEPROD(($B$1:B$1)*($B2:B2));2))/C$1);0)

Voilou

Bonne journée à tous

@+

Edit : Abcd : je n'avais pas fait attention à l'alternative que tu proposais et qui est bien meilleure, car plus courte.

@+
 
Dernière édition:

abcd

XLDnaute Barbatruc
Re : Aide Comment je peut compter une valeur monétaire

Bonjour Tibo,

Le problème provient effectivement du processeur.
Les données sont affichées en valeurs décimales, le processeur calcule en binaire et le résultat est à nouveau affiché en valeur décimale.

D'où petite imprécision possible à partir du septième chiffre après la virgule, normalement sans conséquence, sauf dans le cas présent.

Affiche les résultats de ta formule avec dix décimales, tu comprendras.
L'entier de 1.9999999561 est 1
L'entier de l'arrondi de 1.9999999561 est 2

abcd
 
Dernière édition:

Discussions similaires

Statistiques des forums

Discussions
312 001
Messages
2 084 481
Membres
102 581
dernier inscrit
Michou