Addition sans tenir compte des doublons

N

Nicolas

Guest
Bonjour le forum,

après avoir utiliser le mode rechercher pour savoir si je ne trouverais pas mon bonheur sans avoir besoin de vous poser la question, je reviens un peu bredouille et donc dans l'obligation de poser mon interrogation.

Voilà j'ai différentes colonnes dans une feille excel. dans la première il y a des noms qui reviennent souvent. j'aimerais effectuer le total de ses noms mais sans qu'il tiennent compte des doublons éventuels.

Ainsi par exemple:
Col A
aa
bb
aa
cc
aa
aa
cc
aa

il faudrait qu'excel m'indique: Total des noms: 3

je n'y arrive pas.

Merci
 
N

Nicolas

Guest
Merci pour ces formules mais je n'ai pas l'impression que cela marche.

J'utilise la formule SOMMEPROD en tapant cela:
=SOMMEPROD(1/NB.SI(A2:A20;A2:A20)).
Et la valeur obtenu ne correspond pas du tout à ce que je trouve en le faisant à la main.

Je pense que je dois me tromper quand je rentre les données de la plage mais bon ma colonne A n'a que 20 lignes et je veux le total sans doublons de la ligne 2 à la ligne 20/

Donc... A2:A20

Que faire.

Cordialement
 

Sylvie

XLDnaute Accro
Re bonjour Nicolas, Monique, le forum

si le résultat attendu est bien le nombre de valeurs différentes contenues dans tes cellules A2 à A20, la formule avec SOMMEPROD doit fonctionner. Si ce n'est pas le cas, joins nous ton fichier.

Message édité par: Sylvie, à: 27/10/2005 11:56
 

Discussions similaires

Statistiques des forums

Discussions
312 871
Messages
2 093 102
Membres
105 627
dernier inscrit
jean-marc.brillant