3 clauses et écart de tolérance

sri75

XLDnaute Occasionnel
Bonjour j'essaye de faire une formule qui regrouperait mes 3 clauses suivantes

=SI(OU(((s_totCP+s_totCR)-V_TBSAI)>15;(V_TBSAI-(s_totCP+s_totCR))>15);"X";"")
=SI(OU(((s_totCP+s_totCR)-V_TBGSAI)>15;(V_TBGSAI-(s_totCP+s_totCR))>15);"X";"")
=SI(OU(((s_totCP+s_totCR)-V_ASSRESNET)>15;(V_ASSRESNET-(s_totCP+s_totCR))>15);"X";"")

actuellement j'ai une dernière formule qui teste les résultats des 3 autres
=SI(ET(G107="X";G108="X";G109="X");"PB";"OK")
la 1ere étant en G107 etc...

Merci pour vos idées sur le sujet
 

mécano41

XLDnaute Accro
Re : 3 clauses et écart de tolérance

Bonjour,

Essaie ce code, il me semble que cela donne ce que tu cherches :

Code:
=SI(OU(ABS((s_totCP+s_totCR)-V_TBSAI)>15;ABS((s_totCP+s_totCR)-V_TBGSAI)>15;ABS((s_totCP+s_totCR)-V_ASSRESNET)>15);"Pb";"Ok")

Cordialement
 
Dernière édition:

sri75

XLDnaute Occasionnel
Re : 3 clauses et écart de tolérance

Malheureusement ca ne marche pas les 3 clauses sont cumulatives il doit y avoir trois X pour mettre en anomalie.

si mon résultat est > ou < à 15 alors X .

et si j'ai trois X alors je suis en anomalie si j'ai 1 X ou 2 X je ne suis pas en anomalie.

Merci de ton aide
 

jmd2

XLDnaute Accro
Re : 3 clauses et écart de tolérance

hello

je t'encourage à ne pas compacter ta formule, au cas où tu aies à la remodifier dans 6 mois ce sera plus clair.

au besoin, crée une zone réservée aux calculs intermédiaires dans ton classeur
 

Discussions similaires

Statistiques des forums

Discussions
312 017
Messages
2 084 655
Membres
102 628
dernier inscrit
alexduf971