VBA : l'enregistreur de macro refuse d'enregistrer ma formule (sommeprod)

dionys0s

XLDnaute Impliqué
Bonjour le forum

Je démarre l'enregistreur de macro, je tape la formule suivante

=SOMMEPROD(('Datas CA'!$B$2:$B$65536='Calcul CA'!$B9)*(('Datas CA'!$A$2:$A$65536='Calcul CA'!$C$4)+('Datas CA'!$A$2:$A$65536='Calcul CA'!$D$4)+('Datas CA'!$A$2:$A$65536='Calcul CA'!$E$4)+('Datas CA'!$A$2:$A$65536='Calcul CA'!$E$5)+('Datas CA'!$A$2:$A$65536='Calcul CA'!$F$4)+('Datas CA'!$A$2:$A$65536='Calcul CA'!$F$5)+('Datas CA'!$A$2:$A$65536='Calcul CA'!$G$4)+('Datas CA'!$A$2:$A$65536='Calcul CA'!$H$4)+('Datas CA'!$A$2:$A$65536='Calcul CA'!$I$4))*('Datas CA'!$G$2:$G$65536))

, et la macro refuse de s'enregistrer. C'est normal ? Je comprends pas très bien pourquoi.
Si vous avez une idée...
 
Dernière édition:

mth

XLDnaute Barbatruc
Re : VBA : l'enregistreur de macro refuse d'enregistrer ma formule (sommeprod)

Bonjour,

Bizarre bizarre :)
De mon coté en faisant comme toi j'obtiens ce code (si formule saisie en A1):
Code:
ActiveCell.FormulaR1C1 = _
        "=SUMPRODUCT(('Datas CA'!R2C2:R65536C2='Calcul CA'!R[8]C2)*(('Datas CA'!R2C1:R65536C1='Calcul CA'!R4C3)+('Datas CA'!R2C1:R65536C1='Calcul CA'!R4C4)+('Datas CA'!R2C1:R65536C1='Calcul CA'!R4C5)+('Datas CA'!R2C1:R65536C1='Calcul CA'!R5C5)+('Datas CA'!R2C1:R65536C1='Calcul CA'!R4C6)+('Datas CA'!R2C1:R65536C1='Calcul CA'!R5C6)+('Datas CA'!R2C1:R65536C1='Calcul CA'!R4C7)+('Datas CA'!R2C1:R65536C1='Calcul CA'!R4C8)+('Datas CA'!R2C1:R65536C1='Calcul CA'!R4C9))*('Datas CA'!R2C7:R65536C7))"

Tu as peut-être fait une mauvaise manip ??? tes onglets "Calcul CA" et "Datas CA" existent bien ?
Tu as bien arrêté l'enregistreur à la fin de ta saisie ?
Désolée ... je ne vois pas trop pour l'instant .... :eek:
@ +
mth
 

dionys0s

XLDnaute Impliqué
Re : VBA : l'enregistreur de macro refuse d'enregistrer ma formule (sommeprod)

Là je dois partir du boulot et j'ai toujours pas trouvé. J'essaierai en rentrant directement le code. Mais demain. Je fatigue pour aujourd'hui.

Merci beaucoup ceci dit !
 

eriiic

XLDnaute Barbatruc
Re : VBA : l'enregistreur de macro refuse d'enregistrer ma formule (sommeprod)

Bonsoir,

Trop tard pour chercher pourquoi mais sur 2003 j'ai le même message que toi...
Enregistrement correct sur 2010 mais erreur 1004 à l'exécution

eric
 

Discussions similaires

Réponses
1
Affichages
684

Statistiques des forums

Discussions
299 806
Messages
1 979 239
Membres
206 641
dernier inscrit
Kara89