Trop de niveaux d'imbrication ?

Samantha

XLDnaute Accro
Bonjour,

voici la formule qui me pose problème :

=SI(OU(V29="vrp";R29>DATE(anneeaujourdhui;1;1);R29="");0;SI(AA29<0,8;SI(R29<=DATE(2004;5;7);AA29*20*DATEDIF(R29;DATE(anneeaujourdhui;1;1);"y");SI(AA29*SOMME(20;DATEDIF(DATE(2005;1;1);DATE(anneeaujourdhui;1;1);"y")*20)<8;8;SI(AA29*20*DATEDIF(R29;DATE(anneeaujourdhui;1;1);"y")<15;15;AA29*20*DATEDIF(R29;DATE(anneeaujourdhui;1;1);"y"))));SI(R29<=DATE(2004;5;7);SOMME(20;DATEDIF(DATE(2005;1;1);DATE(anneeaujourdhui;1;1);"y")*20);SI(DATEDIF(R29;DATE(anneeaujourdhui;1;1);"m")<12;0;SI(ANNEE(R29)<2006;ARRONDI(20*DATEDIF(R29;DATE(anneeaujourdhui;1;1);"y")+DATEDIF(R29;DATE(ANNEE(R29)+1;1;1);"m")*(20/12);0);20*DATEDIF(R29;DATE(anneeaujourdhui;1;1);"y"))))))

Sans la fonction ARRONDI cette formule fonctionne sans soucis.

Cependant le format du résultat ne me satisfaisant pas j'ai absolument besoin d'un arrondi (pas possible de jouer sur le format de cellule car c'est la valeur ENTIERE dont j'ai besoin pour des calculs ultérieurs dans les quels je ne peux pas non plus intéger cette fonction.

Lorsque j'ajoute la partie en rouge, Excel me réponds que la formule contient plus de niveaux d'imbrication que supportés par le format du fichier :confused: et quand je valide la partie sélectionné de la formule c'est ce qui est en orange ci-dessus.

Moi y'en a plus rien comprendre

Un chtit coup de main siouxpliz ?

Merci d'avance de vous pencher sur mon problème.


Sam
 

Jiheme

XLDnaute Accro
Re : Trop de niveaux d'imbrication ?

Bonjour Samantha Re le forum

Pourquoi pas utiliser des cellules "relais" dans une zone inoccupée de ta feuille et reprendre ces données pour ton calcul final.

Tu masque les "relais" et le tour est joué.

A+
 

Tibo

XLDnaute Barbatruc
Re : Trop de niveaux d'imbrication ?

Bonjour,

Il est également possible de nommer certaines parties de la formule qui se répètent.

Ca permet parfois de gagner quelques niveaux d'imbrications et améliore surtout la lisibilité de la formule.

Bon app

@+
 

Samantha

XLDnaute Accro
Re : Trop de niveaux d'imbrication ?

Bonjour Tibo, Jiheme,

J'ai continué le nommage de tout ce que je pouvais nommer mais le pb subsiste :
c'est à partir du DATE en rouge que ça coince :

=SI(OU(V29="vrp";R29>_01_01_aujourdhui;R29="");0;SI(AA29<0,8;SI(R29<=_07_05_2004;AA29*20*DATEDIF(R29;_01_01_aujourdhui;"y");SI(AA29*SOMME(20;acquit_du_1_1_5_au_1_1_aujourdhui)<8;8;SI(AA29*20*DATEDIF(R29;_01_01_aujourdhui;"y")<15;15;AA29*20*DATEDIF(R29;_01_01_aujourdhui;"y"))));SI(R29<=_07_05_2004;20+(acquit_du_1_1_5_au_1_1_aujourdhui);SI(DATEDIF(R29;_01_01_aujourdhui;"m")<12;0;SI(ANNEE(R29)<2006;ARRONDI(20*DATEDIF(R29;_01_01_aujourdhui;"y")+DATEDIF(R29;DATE(ANNEE(R29)+1;1;1);"m")*(20/12);0);20*DATEDIF(R29;_01_01_aujourdhui;"y"))))))

Et à ce niveau je ne peux rien nommer puisque c'est une formule à appliquer sur toute une colonne et la référence à la ligne 29 varie donc de ligne en ligne.

Encore une idée ?

Merci de votre aide.


Sam
 

Tibo

XLDnaute Barbatruc
Re : Trop de niveaux d'imbrication ?

re,

il me semble que tu pourrais nommer cette partie dans ta formule :

DATEDIF(R29;_01_01_aujourdhui;"y")

et aussi :

DATEDIF(R29;_01_01_aujourdhui;"y")

Sans le fichier pour tester, je te laisse tester.

@+
 

Samantha

XLDnaute Accro
Re : Trop de niveaux d'imbrication ?

Re :

Compte tenu de l'incrémentation de l'opérande R29 lors de la recopie vers le bas (R29 n'est pas une référence absolue mais bien relative selon la ligne dans laquelle se trouve cette formule) je ne vois pas comment je puis nommer cette fonction.

Peux tu m'expliquer ?

Merci d'avance



Sam
 

Tibo

XLDnaute Barbatruc
Re : Trop de niveaux d'imbrication ?

re,

Pour nommer cette partie de formule :

Insertion - Nom - Définir :

Nom : formule_1
Fait référence à : =DATEDIF(R29;_01_01_aujourdhui;"y")

Normalement, en ligne 29 (je suppose que la formule va en ligne 29), tu mets ta formule en y intégrant les formules nommées.

En recopiant vers le bas, la formule nommée va s'adapter automatiquement pour devenir R30 puis R31 puis...

Sinon, mets nous un petit bout de fichier exemple pour que ce soit plus clair.

A te (re)lire

@+
 

Samantha

XLDnaute Accro
Re : Trop de niveaux d'imbrication ?

Re:

Ak OK, j'ignorais que le nommage pouvait faire intégrer des références relatives.

Cette précision faite je vais même synthétiser encore plus ma formule :)

Merci Tibo.

Bonne fin de journée


Sam
 

Statistiques des forums

Discussions
312 017
Messages
2 084 647
Membres
102 627
dernier inscrit
duval16