XL 2013 Transpose en ligne à chaque date trouvée

Romain31

XLDnaute Occasionnel
Bonjour à tous,

J'ai récupéré des données d'un fichier PDF qui se sont collées dans la colonne A
Bien que les blocs que je cherche à isoler et transposer soient constitués de 6 cellules, je m'aperçois que certains n'en n'ont que 5
Aussi, le critère de séparation étant une date,
A chaque fois que la colonne A contient une date, il faudrait aligner le bloc de cellules la concernant.

Un fichier exemple plus pertinent qu'un long discours

Un grand merci pour vos contributions et bon week-end à chacun(e).

Romain
 

Pièces jointes

  • exemple.xlsm
    12.7 KB · Affichages: 10

job75

XLDnaute Barbatruc
Bonsoir Romain31, Phil69970,

Une solution par formules avec en E1, à tirer vers le bas :
Code:
=SI(ESTTEXTE(A1);"";A1)
Et en F1, à tirer à droite et vers le bas :
Code:
=SI(E1="";"";SI(ESTTEXTE(DECALER($A1;COLONNES($E1:E1);));""&DECALER($A1;COLONNES($E1:E1););""))
A+
 

Pièces jointes

  • exemple.xlsx
    14.9 KB · Affichages: 4

Discussions similaires

Statistiques des forums

Discussions
313 329
Messages
2 097 235
Membres
106 883
dernier inscrit
Papalo