XL 2010 supprimer un chiffre si et seulement si placé en début de cellule

sebbbbb

XLDnaute Impliqué
bonjour

je m'arrache les cheveux pour trouver une formule. Je souhaiterai que si une cellule commence par un chiffre une autre cellule reprenne les mêmes élément mais sans le chiffre ( si et seulement si le chiffre apparaît en début de cellule)

ex :
cellule A1 : 12 remorques vides
devienne en cellule A2 : remorques vides

par contre si A1 = remorque vide
alors A2 s'écrit à l'identique

si A1 = remorque 19 vide
là aussi A2 s'écrit à l'identique

Merci beaucoup a vous
seb
 

job75

XLDnaute Barbatruc
Bonjour sebbbbb, CISCO, Boo2bafoot,

Une autre solution :
Code:
=SUPPRESPACE(STXT(A1;MAX(1;ESTNUM(-GAUCHE(A1))*TROUVE(" ";A1&" "));9^9))
Noter que TROUVE(" ";A1&" ") évite de renvoyer une erreur s'il n'y a aucun espace en A1.

Remarquer que cette formule évite la fonction SI grosse consommatrice d'octets en mémoire :

- formule de CISCO => 68 octets (mais elle serait à compléter car elle donne un espace superflu)

- formule de Boo2bafoot => 71 octets

- formule de job75 => 56 octets.

A+
 

job75

XLDnaute Barbatruc
Re,

Si le nombre en tête n'est pas toujours séparé du reste par un espace :
Code:
=SIERREUR(--GAUCHE(A1;SOMMEPROD(--ESTNUM(-(GAUCHE(A1;LIGNE(INDIRECT("1:"&NBCAR(A1))))&0))));"")
Edit : &0 est nécessaire au cas où le texte qui suit commence par " a" ou " p", voyez ce fil :

https://www.excel-downloads.com/threads/12-a-ou-12-p.20019156/

En outre cela permet de récupérer des nombres négatifs.

Bonne nuit.
 
Dernière édition:

Statistiques des forums

Discussions
312 885
Messages
2 093 256
Membres
105 658
dernier inscrit
Mario Richard