Sommeprod : faire référence au contenu stric et entier d'une cellule

lilubell

XLDnaute Nouveau
Bonjour ,

Je vous fais part de mon problème car je planche dessus sans succès depuis trop longtemps...

ma formule est la suivante :
=SOMMEPROD((ESTNUM(CHERCHE(D3;INDIRECT(C3)))*(Réponses='Analyse RPS'!$E$2)))

dans C3 j'ai collé des noms de plages telles "statut", "contrat", "age",
dans D3 j'ai collé des noms de plages telles : "Technicien, agent de maîtrise", "Agent", "médecin", ..., "- de 25 ans", "entre 25 et 29 ans", etc

alors je ne comprends pas comment excel cherche les données dans la plages indiquées,
mais il semble que parfois, il ne "lit" pas le contenu strict et entier de la cellule, de façon que pour le nom "Technicien , agent de maitrise", il retrourne des chiffres corrects mais pour "agent" il va additionner les résultats de "technicien agent de maîtrise" et de "agent".

Il appraît la même chose avec des noms comme "SSE", "SSP", "Agressions" qui contiennent 2 "S"...

Egalement lorsque je mets une cellule vide en D3 (je veux connaitre les résultats pour les cellules vides dans la plage indiquée), excel ne comprend pas et me renvoi tous les résultats.

Je voudrais trouver un moyen de faire référence au contenu strict et entier de la cellule mentionnée.
Avez-vous une idée ?

je peux vous transmettre un morceau de mon fichier ci-nécessaire.


Merci tellement !
 

lilubell

XLDnaute Nouveau
Re : Sommeprod : faire référence au contenu stric et entier d'une cellule

Voici la pièce jointe en attaché !

Merci de prendre le temps !
 

Pièces jointes

  • Classeur1.xlsx
    292.6 KB · Affichages: 50
  • Classeur1.xlsx
    292.6 KB · Affichages: 54
  • Classeur1.xlsx
    292.6 KB · Affichages: 64

Dugenou

XLDnaute Barbatruc
Re : Sommeprod : faire référence au contenu stric et entier d'une cellule

Bonjour,
Avant d'ouvrir ton fichier je dirai que tu obtiens le résultat demandé par ta formule : CHERCHE(agent... renverra un num pour agent de maitrise et pour agent d'entretien. C'est moins clair pour SSE et SSP dans agression. Je ferai plutot un égal du genre :
SOMMEPROD((D3=INDIRECT(C3))*(Réponses='Analyse RPS'!$E$2))
mais pour être sûr, je vais regarder ton fichier
Cordialement

Je confirme après avoir regardé le fichier : =SOMMEPROD((D3=INDIRECT(C3))*(Réponses='Analyse RPS'!$H$2))

mais bonjour les temps de calcul !
 
Dernière édition:

Dugenou

XLDnaute Barbatruc
Re : Sommeprod : faire référence au contenu stric et entier d'une cellule

Bonjour,
pas dans le fichier que tu as mis en ligne.
J'ai seulement un ref en bas de tableau pour les valeurs qui n'existent pas
 

Pièces jointes

  • lilubel.xlsx
    292.9 KB · Affichages: 50

lilubell

XLDnaute Nouveau
Re : Sommeprod : faire référence au contenu stric et entier d'une cellule

Salut,

merci pour ta réponse Dugenou.
Bon je ne sais pas pourquoi la formule me renvoyait #valeur.

En tout cas, le problème que je décrivais arrive :
J'ai calculé manuellement le résultat que je suis censé obtenir sur les paramètres très faible et agent (cellule E5) : je dois obtenir 4662 et non 6501 comme j'obtiens actuellement, car 6501 = 4662 + 1839
1839 étant le résultat obtenu pour le paramètre "technicien, agent de maîtrise" et "très faible" (cellule E3).
donc ce que je comprends c'est que pour le paramètre "agent" excel renvoie à la fois les données de "Agent" et de "techicien, agent de maîtrise".

Suis-je claire ? comment contourner ce problème (sans changer le texte, ce serait préférable, car le problème arrive sur d'autres cellule) ?
 

Jocelyn

XLDnaute Barbatruc
Re : Sommeprod : faire référence au contenu stric et entier d'une cellule

Bonjour le Forum,
Bonjour lilubell, Hasco, Dugenou,

Ton soucis vient du fait que tu cherche le terme Agent et que ce terme existe aussi dans "technicien, agent de maîtrise", je te propose donc d'ajouter une condition qui regarderait le nombre de caractère de la cellule de cette façon

Code:
=SOMMEPROD((NBCAR(D5)=NBCAR(INDIRECT(C5))*(ESTNUM(CHERCHE(D5;INDIRECT(C5)))*(Réponses=$'Analyse RPS'.$E$2))))

A tester en E5 je l'ai étirée vers le haut jusqu'en E3 cela a l'air d"e fonctionner

Cordialement
 

Dugenou

XLDnaute Barbatruc
Re : Sommeprod : faire référence au contenu stric et entier d'une cellule

Salut Lilubel, salut Jocelyn
Dans le fichier joint ci dessus le résultat est de 4662 : tu n'as pas dû changer la formule : il faut enlever le estnum(cherche... pour laisser seulement D3 =
come le redis justement Jocelyn
Cordialement
 

lilubell

XLDnaute Nouveau
Re : Sommeprod : faire référence au contenu stric et entier d'une cellule

Bonjour

Merci pour vos réponses,

J'ai l'air d'insister mais je ne comprends pas tout : pourquoi la formule de Jocelyne me renvoi aucune valeur...

J'ai dû louper qqch. Je vous renvoi mon fichier...
 

Pièces jointes

  • lilubel(2).xlsx
    285.7 KB · Affichages: 42

lilubell

XLDnaute Nouveau
Re : Sommeprod : faire référence au contenu stric et entier d'une cellule

J'ai essayé ce que me propose Dugenou et Jocelyn


=SOMMEPROD((NBCAR(D3)=NBCAR(INDIRECT(C3))*(D3;INDIRECT(C3)))*(Réponses='Analyse RPS'!$E$2))Pourtant je n'ai que des #valeur en retour...

Si ça marche chez vous, pouvez-vous m'envoyer votre fichier ?

Voici le mien si vous être en mesure de décortiquer cela...



Merci !
 

Pièces jointes

  • lilubel(3).xlsx
    285.7 KB · Affichages: 36
  • lilubel(3).xlsx
    285.7 KB · Affichages: 36
  • lilubel(3).xlsx
    285.7 KB · Affichages: 43

Dugenou

XLDnaute Barbatruc
Re : Sommeprod : faire référence au contenu stric et entier d'une cellule

Bonjour,

=SOMMEPROD((NBCAR(D3)=NBCAR(INDIRECT(C3))*(D3;INDIRECT(C3)))*(Réponses='Analyse RPS'!$E$2))
=SOMMEPROD((NBCAR(D3)=NBCAR(INDIRECT(C3))*(D3=INDIRECT(C3)))*(Réponses='Analyse RPS'!$E$2))

et à mon avis ceci suffit :
=SOMMEPROD(($D3=INDIRECT($C3))*(Réponses='Analyse RPS'!E$2)) recopier en bas et à droite

Cordialement
 

Pièces jointes

  • lilubel(3).xlsx
    287.4 KB · Affichages: 40
  • lilubel(3).xlsx
    287.4 KB · Affichages: 35
  • lilubel(3).xlsx
    287.4 KB · Affichages: 38
Dernière édition:

Statistiques des forums

Discussions
313 320
Messages
2 097 130
Membres
106 848
dernier inscrit
toufk