Microsoft 365 Somme.si.ens conditionnelle

vigehts

XLDnaute Nouveau
Bonjour,
J'ai un problématique que je n'arrive pas à ressoudre.
Sur le ficher excel, je fais une somme.si.ens pour inclure à une commande et un compte une réduction appliquée. Cependant j'aimerais la conditionner à l'existence d'une ligne discount dans ma colonne article.
J'ai essayé avec plusieurs si mais sans résultats pour l'instant. ( je n'ai pas d'autres clés disponibles)

j'ai ça =SI(D2<0;0;SOMME.SI.ENS(D:D;A:A;A2;C:C;C2))

Par exemple : Pour une commande donnée et un compte donné, s'il existe une ligne discount associée a ces même variables, alors je fais ma somme.si.ens. Sinon je garde la valeur montant. Ici ma somme marche mais elle se fait aussi pour les lignes 3 & 4, ce que je ne veux pas.

CommandeARTICLECompteMontantCA
3518​
1​
001102
37 900 €​
29 702 €​
3518​
2​
201102
2 698 €​
1 349 €​
3518​
4​
101102
3 790 €​
5 690 €​
3518​
3​
101102
1 900 €​
5 690 €​
3518​
6​
801000
159 €​
159 €​
3518​
DISCOUNT001102
-8 198 €​
0 €​
3518​
DISCOUNT201102
-1 349 €​
0 €​


Merci d'avance
 

Deadpool_CC

XLDnaute Impliqué
Re ...

Essaye avec cette formule :
VB:
=SI(NB.SI.ENS(A2:A8;A2;C2:C8;C2;B2:B8;"REDUCTION");SI(D2<0;0;SOMME.SI.ENS(D:D;A:A;A2;C:C;C2));D2)

Si c'est bon , pense à cocher Solution dans la partie grise à droite du post
 

Pièces jointes

  • exemple.xlsx
    9.8 KB · Affichages: 4

soan

XLDnaute Barbatruc
Inactif
Bonsoir vigehts, Deadpool,

bienvenue sur le site XLD ! :)

Image 1.jpg


moi j'aime bien les formules joyeuses ! 😄 comme dirait Coluche : « elle est toute gaite ! » (sketch sur la publicité des "Interdits de Coluche") ; pour éviter le smiley automatique, y'a ces 2 solutions :​

1) taper D: D (oui, avec un espace en plus entre « : » et le 2ème D)

2) utiliser la balise "Code (dans le texte)" : D:D

Image 2.jpg




Si c'est bon, pense à cocher Solution dans la partie grise à droite du post

je précise que c'est comme ça (juste sous le numéro de vote) :

Coche.jpg


à faire sur le post de Deadpool_CC qui a solutionné ton exo.

soan
 

Discussions similaires

Statistiques des forums

Discussions
299 930
Messages
1 980 159
Membres
207 010
dernier inscrit
Setry