somme + recherche

noemie45

XLDnaute Occasionnel
Bonjour je voudrais faire une somme de plusieurs valeurs, sans utiliser la formule index ou equiv

voici un fichier joint pour que cela soit plus parlant.
 

Pièces jointes

  • SOMME RECHERCHE.xls
    15.5 KB · Affichages: 51
  • SOMME RECHERCHE.xls
    15.5 KB · Affichages: 52
  • SOMME RECHERCHE.xls
    15.5 KB · Affichages: 52

JHA

XLDnaute Barbatruc
Re : somme + recherche

Bonjour,

Un essai avec sommeprod()
=SOMMEPROD(($B$2:$M$2<=$B$18)*($B$14:$M$14))
ou
=SOMME.SI($B$2:$M$2;"<="&B18;B14:M14) formule matricielle à valider par Ctrl+Maj+Entrée

JHA
 
Dernière édition:

hoerwind

XLDnaute Barbatruc
Re : somme + recherche

Bonjour,

Une proposition sans la fonction INDEX :
=SOMME(DECALER(A14;;;;EQUIV(B18;A2:M2;0)))

Une proposition sans les fonctions INDEX et EQUIV :
=SOMME(DECALER(A14;;;;MOIS(1&B18)+1))
à tester sur une version US, car sous ma version FR j'ai du modifier may en mai (B18) pour obtenir le résultat

Edition : salut JHA, pas vu
 

Tibo

XLDnaute Barbatruc
Re : somme + recherche

Bonjour,

Ne pas voloir utiliser INDEX ou EQUIV complique un peu les choses.

Cela dit, une proposition :

Code:
=SOMME(DECALER($A$2;2;1;10;SOMMEPROD(($B$2:$M$2=B18)*COLONNE($B$2:$M$2))))

Je te laisse tester

@+
 

Discussions similaires

Statistiques des forums

Discussions
312 875
Messages
2 093 148
Membres
105 641
dernier inscrit
Naoel