Microsoft 365 REMPLISSAGE SELON UNE DATE

Moi69

XLDnaute Occasionnel
Bonjour le Forum et Bonne Année

Je suis à la recherche d'une formule qui doit certainement être simple, mais je ne la trouve pas.
Mon souci : je voudrais qu'une cellule me donne le nombre de jours restants selon différentes dates
Un dessin valant plus qu'un long discours, je mets en PJ ma feuille.

Le résultat souhaité serait :
Ma date de référence se situe en D3 (ici le 9/9/2022)
Il faudrait donc que de D17 à D24 le résultat soit 0
En D25 = 22
En D26 = 31
En D27 = 30
En D28 = 31

J'espère avoir été assez clair et je vous remercie d'avance pour les solutions que vous allez m'apporter.
 

Pièces jointes

  • TEST.xlsx
    20.9 KB · Affichages: 8

Hasco

XLDnaute Barbatruc
Bonsoir,

Je ne sais pas si je suis dans votre logique, mais s'il s'agit de calculer le nombre de jours cumulés entre le 1/9/2022 et la fin d'un mois égal ou supérieur à cette date, alors de D17 à D28 :
=SI($C17>=$D$10;(FIN.MOIS(C17;0)-$E$3)+1;0)
Vous donnera de Septembre à Décembre 2022 :
septembre-2222
octobre-2253
novembre-2283
décembre-22114

Pour des données non cumulées :
=SI($C17>=$D$10;(FIN.MOIS(C17;0)-$E$3)+1-SOMME($D$16:$D16);0)
Vous donnera :
septembre-2222
octobre-2231
novembre-2230
décembre-2231

Autre détail, si c'est la fin de mois de C17:C28 qui compte dans vos calculs, alors vous pourriez avoir dans ces cellules (à tirer de D17 à D28)
=FIN.MOIS(MOIS.DECALER($C$33;LIGNE(1:1)-1);0)
Où Ligne(1:1) vous permet de retourner un nombre de 1 à n

Et en $D17:$D28 :
=SI($C17>=$D$10;(C17-$E$3)+1-SOMME($D$16:$D16);0)
Comme dans le fichier ci-joint

Voyez également en J17:J28 pour exemple la formule suivante qui permet de faire l'économie de la somme des jours précédents :
=SI($C17=FIN.MOIS($E$3;0);$C17-$E$3+1;SI($C17>FIN.MOIS($E$3;0);JOUR($C17)))

Et en colonne K, la plus courte et ma préférée :
=SI($C17>$D$10;MIN($C17-$E$3+1;JOUR($C17)))

cordialement
 

Pièces jointes

  • Moi69 TEST.xlsx
    26.9 KB · Affichages: 5
Dernière édition:

Discussions similaires

Réponses
0
Affichages
972
Réponses
4
Affichages
1 K

Statistiques des forums

Discussions
299 792
Messages
1 979 141
Membres
206 584
dernier inscrit
LLJoad