remplacer valeurs

sabine2304-87

XLDnaute Nouveau
Bonjour,
Nouvelle venue, avec un niveau trop moyen en Excel. Je me lance :
J'ai plusieurs tableaux déjà complétés via liste déroulante de choix. Comment puis je remplacer les données déjà saisies par un chiffre : dans le cas ci joint, j'aimerai que les quatre choix :
Major (devienne chiffre 3 )
Significant (devienne chiffre 2 )
Moderate (deveinne chiffre 1)
Negligible (devienne chiffre 0) .

Merci et bonne fin de journée à tous.
 

Pièces jointes

  • exemple tri et chiffre.xlsx
    27.8 KB · Affichages: 7

JHA

XLDnaute Barbatruc
Bonjour à tous,

Par ligne
VB:
=(NB.SI($B2:$G2;"Major")*3)+(NB.SI($B2:$G2;"Significant")*2)+(NB.SI($B2:$G2;"Moderate"))
Par colonne
Code:
=(NB.SI(B$2:B$7;"Major")*3)+(NB.SI(B$2:B$7;"Significant")*2)+(NB.SI(B$2:B$7;"Moderate"))

JHA
 

Pièces jointes

  • exemple tri et chiffre (2).xlsx
    23.1 KB · Affichages: 8

Laurent78

XLDnaute Occasionnel
Bonjour,

si c'est du one shot, CTRL + H 4 fois de suite comme l'indique SirReginald.

Autre solution que celle de JHA :

mettre dans une cellule en dessous du tableau
Code:
=RECHERCHEV('FEUILLE 1 '!B2;'list '!$A$1:$B$4;2;FAUX)

Puis "tirer" à droite et en bas, puis copier/collage spécial valeur

Si par clair, nous le dire
@+
 

Statistiques des forums

Discussions
313 296
Messages
2 096 923
Membres
106 788
dernier inscrit
Pragmatis