Remplacer automatiquement un code par un nom complet

Guigui59

XLDnaute Nouveau
Bonjour à tous

J'ai une feuille Excel (version 2003) avec 3 colonnes: un code de 4 lettres en colonne A, un nom scientifique en B et un nom français en C.
Est-il possible,un peu comme avec une correction automatique, de remplacer automatiquement le code par les 3 colonnes complètes? Ex: je tape dans la colonne A "AANT" et j'obtiens en B "Aceras anthropophorum" et en C "Acéras homme pendu".
Comme j'ai plus de 1000 données, j'aimerais avoir une manipulation ne nécessitant pas si possible de réecrire tous les noms :)

J'espère être assez clair, et vous remercie d'avance pour les réponses que vous pourrez me fournir.

Cordialement
Guillaume
 

Staple1600

XLDnaute Barbatruc
Re : Remplacer automatiquement un code par un nom complet

Bonjour


Peux-tu envoyer un extrait (zippé) de ton fichiers (10 lignes suffiront), stp?


EDITION: TU connais la fonction RECHERCHEV ?
tu saiis ton code en A2
en B2
=RECHERCHEV($A2;$D$2:$F$7;2;FAUX)
en C2
=RECHERCHEV($A2;$D$2:$F$7;3;FAUX)

et en D2:F7 (c'est un exemple bien sur)
ton tableau de noms
 
Dernière édition:

JHA

XLDnaute Barbatruc
Re : Remplacer automatiquement un code par un nom complet

Bonjour Guigui, le forum,

Ex: je tape dans la colonne A "AANT" et j'obtiens en B "Aceras anthropophorum" et en C "Acéras homme pendu".
En B1:
=si(A1="AANT";"Aceras anthropophorum";"")
En C1
=si(A1="AANT";"Acéras homme pendu";"")

et tu tires vers le bas

JHA
 

Guigui59

XLDnaute Nouveau
Re : Remplacer automatiquement un code par un nom complet

Re bonjour à tous

Avant toute chose merci à vous pour vos réponses très rapides (je n'en espérais pas tant :))

Je ne connaissais pas la formule RECHERCHEV, je vais essayer ça dès que possible.

Pour Staple1600, je mets tout de même un extrait du tableau.

Encore merci pour vos réponses, je vous tiens au courant de l'évolution!

A bientôt

Petit oubli: j'ai oublié de préciser que le classeur avec les codes et les noms devrait servir de "base de données", dans laquelle je voudrais piocher à chaque nouvel inventaire. C'est-à-dire que je ferais un nouveau classeur Excel pour chaque site inventorié. Est-ce possible de faire des "transferts" comme ceci, entre plusieurs classeurs? Et toujours avec la formule RECHERCHEV? Merci pour vos réponses
 

Pièces jointes

  • Exemple.zip
    1.7 KB · Affichages: 63
  • Exemple.zip
    1.7 KB · Affichages: 67
  • Exemple.zip
    1.7 KB · Affichages: 78
Dernière édition:

Guigui59

XLDnaute Nouveau
Re : Remplacer automatiquement un code par un nom complet

Merci Staple1600

L'exemple que tu m'a renvoyé correspond exactement à ce que je veux faire! Par contre j'ai peur de ne pas bien comprendre la manipulation que tu as faite pour obtenir ce résultat :(

Désolé de te demander ça, mais pourrais-tu (quand tu as le temps, ne t'embête pas exprès pour moi!) détailler ce que tu as fait pour obtenir le classeur envoyé? Ca me permettrait de le refaire ensuite, et de faire partager mes nouvelles connaissances avec mes collègues!

Merci d'avance!
 

Staple1600

XLDnaute Barbatruc
Re : Remplacer automatiquement un code par un nom complet

Re


1) J'ai nommé la plage de cellules contenant les noms scientifiques
Sélection des cellules: Feuil1!A2:C10
(Insertion/Noms/Définir J'ai donné le nom : tableau

2) J'ai nommé les codes (Feuil2!A1:A10) : codes

3) En feuille 2

En A1, sélection de la cellule puis
Données/Validation/Liste
Source:
=codes


4) Toujours sur la feuille 2

J'ai utilisé la formule RECHERCHEV

• en C1
=RECHERCHEV($A1;tableau;3;FAUX)

• en D1
=RECHERCHEV($A1;tableau;2;FAUX)

* dans l'aide d'Excel, tu trouveras des détails sur la fonction RECHERCHEV

Voilà, dis-moi si mes explicaztions sont assez claires.
 

Guigui59

XLDnaute Nouveau
Re : Remplacer automatiquement un code par un nom complet

Re

Merci beaucoup Staple1600, ta description est super! ça fonctionne impec'!! Je n'ai fait que recopier tes formules, mais promis je vais aller voir l'aide d'Excel pour comprendre le "fonctionnement" de la formule RECHERCHEV et essayer de la réappliquer.

Encore merci pour ta patience, et merci aussi à tototiti2008, JHA et chris pour leurs réponses!

Bonne soirée
Guillaume
 

Discussions similaires

Réponses
22
Affichages
949

Statistiques des forums

Discussions
312 885
Messages
2 093 256
Membres
105 658
dernier inscrit
Mario Richard