Regroupement par intervalle d'heure

diozea

XLDnaute Nouveau
Bonjour,

J'ai une liste d'incidents avec date de début en heure min et date de résolution.

Je souhaite faire un beau tableau pour présenter le nombre d'incident dans les intevalles de durée 0-1h 1h-2h 3h-4h ...


Date de création; Date de résolution
04/03/2011 16:29; 07/03/2011 10:44
16/03/2011 10:08; 05/04/2011 17:32
16/04/2012 14:52 ;17/04/2012 08:35
04/08/2010 09:20 ;04/08/2010 15:54

Avez-vous une idée ?
 

diozea

XLDnaute Nouveau
Re : Regroupement par intervalle d'heure

bonjour kjin,
je souhaite dénombrer le nbre de ticket par durée de résolution. Et non selon l'heure d'ouverture du ticket.
Par exemple, combien de ticket ont duré moins de 1h? Combien ont durée entre 1et 2h?
 

Fred0o

XLDnaute Barbatruc
Re : Regroupement par intervalle d'heure

Bonjour diozea,

As-tu essayé le fichier que j'ai joint à mon post #6 ?

Celui-ci utilise la fonction FREQUENCE, validé par <Shift><Ctrl><Enter>. En regardant comment il est construit, peut-être pourras-tu l'adapter à ton fichier original ?

Ce qu'il faut savoir, c'est qu'il te faut sélectionner la totalité de la plage dans laquelle tu voudras avoir la fonction FREQUENCE, taper la formule et valider l'ensemble par <Shift><Ctrl><Enter>.

Si tu n'y arrives pas, joins-nous ton fichier original sans données confidentielles (si tu peux).

A+
 

diozea

XLDnaute Nouveau
Re : Regroupement par intervalle d'heure

Merci à vous, Le fonction frequence matricielle fonctionne. Il faut effectivement selectionner toute la plage où la formule doit être executé et ensuite <Shift><Ctrl><Enter> (et non pas "tirer" la formule).

J'ai un autre besoin:
je souhaite afficher en derniere colonne et pour chaque incident, l'intervalle de durée auquel il appartient.
Avez-vous une idée comment faire ?
 

Fred0o

XLDnaute Barbatruc
Re : Regroupement par intervalle d'heure

Bonsoir,

Si j'ai bien compris ta dernière question :
Code:
=SIERREUR(INDEX($G$2:$G$74;EQUIV(D2;$G$2:$G$74;1)+1;1);"")

où : $G$2:$G$74 représente la liste des intervalles (00:00, 01:00, 02:00, 03:00, etc)

où : D2 est la valeur de l'intervale que l'on veut catégoriser (par exemple 17:42:47)

Formule à saisir et à tirer vers le bas.

A+
 

Statistiques des forums

Discussions
312 947
Messages
2 093 842
Membres
105 851
dernier inscrit
aviato